Drone is flying but it goes away in stabilize mode

Hi Guys,

I just built an hexa with F550 frame with Navio+/Raspberry2, I used the EMAX 30A ESC coupled with EMAX 2216 motors and 3DR telemetry.
The setup looks fine, I get the telemetry with APM Planner 2.0 and my RC is setup, also ESC are calibrated/set and compass is calibrated also I get GPS fix with HDOP < 2.
However, when I try t takeoff in stabilize mode the drone goes away by itself and it is difficult to keep it not moving.
It goes away always in the same direction and I have to compensate the other way.
I will try to start auto-tune in order to set PID’s. Does someone may have an idea what can cause this behavior ?

Thanks guys.

Do not try autotune if the copter is behaving like that. If you are sure that all the weight is distributed evenly on all motors, try a acc calibration again. If the problem persists, you can do an auto-trim (not autotune). Prepare the copter for flight, hold the sticks in arming position for 15sec (on the APM2.5 the red and blue LEDs start flash, I do not know what the Navios LED does). Takeoff in stabilze mode and try to hold the copter in a stable hover for about 30s. Land and disarm. With the next takeoff, after arming the normal way, the drift should be less or gone.

It also might be worth noting that “stabilize” will not hold copter in one place, it is only holding roll, pitch and yaw at the desired values. Stabilize does not use GPS. If you want copter to stay on one place, mode “Loiter” does just that.

Hi,

It is my first drone and some concept are not completely clear for me. However Sebastian, you made my day :wink: .
Your answer led me to to figure out the root cause.
I performed the manual trim and I figured out that the offset of the trim for roll and pitch was high. Then this led me to figure out that PWM to PPM encoder was causing this offset for roll and pitch, that is why the drone was drifting like crazy.
Now the drift is still there but much less in stabilize mode.
I did not understand well the stabilize mode, I’ll RTFM ahaha, now I understand better and will focus on the Loiter mode thanks Igor.
I really appreciated.
Cheers
PS : Do you know the value of the bitmask to skip the Compass AND the board voltage pre-check ?
Thanks

Bitmask to disable compass and board voltage is:

ARMING_CHECK 123

Wonderfull thank you again.

@fabienmonnier / @igor.vereninov / @schuermannsebastian

Have you tested this procedure https://www.youtube.com/watch?v=ayA0uYOqKX4 for autotrim before? Can I use with Navio+? I am asking because I have the same Fabienmonnier´s behavior.

Additional to that there is a way to modify the pitch and roll gain on the transmiter? Thats why on the first test done it was difficult to control my quad, it means pretty small movements on the control stick on the quad the reactions are abrupt.

Thanks for your recomendations
PD: Weight is good distributed, It is balanced

@Grek

Yes you can do auto trim with the navio. I highly suggest it. This is the 1st thing I do, on the 1st flight with ardupilot. You can even do this from the ground if your frame is very out of balance. But if you are this out of balance your flight time will be horrible because of the extra work the auto pilot has to do to keep it level.

Second thing is always mid throttle! :wink:

As for the roll response. “Rate Roll P” has the greatest effect. You need to bring it down a bit to where you feel comfortable. But this then effects the other Rate Roll PIDS, which then need to be tuned to your adjusted rate roll p.

An easy “patch” until you can do a auto tune or full PID tune is to use the “RC feel” parameter in the basic parameters section on mission planner. This will scale Rate Roll P , I , & D at one time to achieve the desired feel.

:smiley: