Downloading RS2 log files of over 200 MB issue?

I’m having an issue downloading logs from an RS2 which are over 200MB.

Download starts, but almost immediately, Wi-Fi seems to fail, although download seems to proceed in the background. Occasionally, Wi-Fi seems to reconnect. Once file gets to 200MB, it fails completely.

I’ve tried with several different devices, including an iPhone 12, iPad Pro, PC and Android tablet. I’ve also tried with ReachView 2 and 3 and getting similar results.
On iOS, although the file does seem to download, after I email it to myself, the zip file indicates there is an unexpected error.

I’ve managed to get the LLH file (which was about 5MB) but neither the UBX or the Rinex. I am using 27 beta 1 version of the firmware.

I urgently need these logs for a large PPK project as soon as possible. This represents about 12 hours of observation time for which I no longer have access to the site.

Is there way to access the logs over USB or Bluetooth? The links to the guides seem to be broken.

Thanks for any help and guidance.

1 Like

Can you move closer to your Wifi access point or in some other way improve the signal?

Thanks for the response. I’ve placed the RS2 within 3 feet of the router. I also tried putting the RS2 in hotspot mode and placing the RS2 within 3 feet of the PC and other devices.

Same result.

1 Like

What kind of network connection are we talking about (protocol)?
Are you in an urban environment with lots of wifi-signal?

I’m not sure I understand the question. It’s a standard 2ghz Wi-Fi signal. In hotspot mode, I’ve placed the RS2 within 2-3 feet of the PC I’m connecting to. Yes, it’s a fairly dense Wi-Fi area in an urban environment, but I don’t have issues with other devices. I understand Wi-Fi on the RS2 has very limited range (less than 5m or so), possibly because of this.

I’m wondering if it’s a file size limitation. I’m also looking for alternative methods for getting the logs. My understanding is that the USB-C connection is for charging the battery only, but that there may be work around to allow download of files through USB. I also have a sim chip installed on the RS2. Is there a way to get the files through the mobile sim chip?

Thanks again!

An alternative way to get the logs is to use SSH to access the unit and then use the command scp to copy the files over. You can do this from a windows or Linux command line. If your familiar with SSH it’s not complicated, but if not there’s a bit of a learning curve. It’s been a while since I did this but the outline is:

Type: ssh emlid@yourRS2ipaddress
Enter password: emlidreach (or whatever you set it to)

Use ssh commands to navigate to the log folder (commands cd to change directory and LS to list what’s in the directory)

Note the file you want to copy and it’s location.

Then on a separate command line type:
scp emlid@yourunitsIP the filelocationonRS2 theplaceyouwantthefiletogoonyourcomputer

I’m working from memory away from my computer-> so thats the outline, but may not be the exact process. Will require some work on your part with an SSH tutorial if you’ve not used it before, but hopefully it can be a guide in outline form.

1 Like

Hi!

That’s an interesting solution.

I’m having an issue logging in though. It apparently doesn’t like the “emlidreach” password. See attached screenshot.

image

What am I doing wrong? I’m on Windows 10, using Command Prompt. Should I be using something else?

Cheers!

Marc

1 Like

Solved!

At least, sort of. I got my log files though! Thanks to AWD for getting me on the right track. I ended up using WinSCP (HIGHLY recommended, btw!) to transfer the log files from the RS2 to my PC, while GPS was in hotspot mode. I did try through a regular wifi router, but the connection kept timing out, as it did when I tried using ReachView 2 and 3).

One other note is the host name is “reach” not “emlid”. So for those going trying to follow the above tutorial it should read “reach@192.168.41.1” (or whatever the ip is). Password (unless changed) is “emlidreach”.

Transfer speeds were still relatively slow at about 1MB/s. Thanks again to AfricaWaterDoc for the guidance!

Cheers!

Great! Yep, now I remember the login was “reach” not “emlid”. It’s one of the things that’s hidden in the community forum somewhere.

Hi Marc,

It’s indeed possible to get the logs from Reach using WinSCP on Windows. However, the ReachView 3 behavior you faced is not expected, and we would like to investigate it further so that you can download the data in the most straightforward way in the future.

I managed to reproduce the issue with ReachView 3 on an Android device, but not on iOS. Could you please clarify whether the log can be saved fine if you use the Save to Files option on iOS instead of sending the data via email?

If you tried to download the logs only when Reach was connected to an external Wi-Fi network, it would be great to check if the issue persists when you connect to the Reach hotspot.