DJI M300 RTK without NTRIP service?

I am working in a remote area with no NTRIP service nearby. I was hoping I could set up my RS2+ as a base over a point I measured with Average Single accuracy and have it send RTK corrections to my M300. I understand the corrections would only be relative to the base and not be absolutely accurate, but that is good enough for this application.

I was able to get the M300 smart controller to connect to my RS2+ but not actually use the corrections. The message I got says, “RTK connected, RTK data not in use.” Before connecting the std deviations were 3.xx and after they went down to 0.xx.

I’m not even sure if it’s possible to send RTK corrections to my M300 without NTRIP service? Any suggestions, ideas, or solutions would be greatly appreciated. Thank You!

Hi Eric.

Did you configure your M300 to receive corrections from the RS2+ via Emlid’s Local Caster? If so, and you couldn’t get it to work. Try using your phone’s hotspot as the host network and connect both the RS2+ and the M300 to the phone and it should work using Local Caster settings. The phone does not have to be connected to the internet for this to work.

The setup is the same as in the following docs.

[edit-grammer]

3 Likes

Hi Dave, I was using my phone as a hotspot for both my RS2+ and my M300. I will read the links you sent and try Emlid Caster tomorrow. Thanks!

Sounds good. Be advised that there are two setups. Emlid Caster and Local Caster. Setting them up is similar but different. After reading the docs and giving it a try. Come on back if you have questions.

2 Likes

Understood, I will let you know if it works…
Thanks again

2 Likes

Hi Eric,

As Dave mentioned, Local NTRIP can be used without the internet, so it comes in handy in remote areas. If there’s cell coverage, you can use Emlid Caster to pass on corrections from Reach RS2+ to DJI M300 RTK.

Let us know how it goes for you.

@dpitman @kirill.pavlyuchuk I was able to get RTK corrections to my M300 using local NTRIP and Emlid Caster. The first time I tried local NTRIP I got the message on my smart controller, “RTK connected, RTK data not in use,” but it worked on the second and third attempt. The first time I tried Emlid Caster I entered the wrong password so obviously it didn’t work. Once I entered the correct password, it started working.

Unfortunately the company I am working for requires me to use some proprietary software on my smart controller, not the Pilot 2 app. And unfortunately their software doesn’t like the Emlid for some reason. Therefore I have to use a D-RTK2 unit, which the company has provided. I would much rather be using my RS2+, but I can’t on this job.

Thanks for you help!

3 Likes

Hi Eric,

Glad to hear that you’ve managed to get corrections. But I’m sorry to know that you’re forced to use another receiver.

Your questions are always welcome!