DJI drones - rtk connected. Rtk data not in use

On my DJI m300 controller it’s saying “rtk connected. Rtk data not in use”. Rs2+ is setup over a know fixed point and I’m using local ntrip. Any idea how to fix it? Also says rtk converging.

1 Like

Have you tried using your phone or tablet’s hotspot to host the network?

Also, to confirm, everything is set-up outside with good gps reception, correct?


Have you tried a different location? Looks like you are at a residence with trees around it. There’s a lot of interference coming out of homes. Also, what were your deviations? Converging is basically their way of saying floating.


Using my Autel EVO Pro V2 RTK at my house with my phones hotspot, I usually can’t get a fixed solution in my yard due to trees/bushes. I don’t have a clear sky view area. Even my Emlid RS2 and Javad Triumph Victor LS has issues. It’s a high multi-path areas.

I usually take off above the trees and house without any RTK then engage the RTK mode. It usually takes less than 10 seconds to get a fix once I have a clear view of the sky. This is using the states RTN.

I’ve managed to use my Victor LS as a base through it’s wifi connection for the UAV. I’ve connected with the RS2 also but you have to have no multi-path.

It’s imperative you have a clear view of the sky for the base and UAV to have a good fix. My EVO will not take off if RTK is engaged and it has no fix.


Same with the Mavic 3E.

1 Like

New location and same issue as before. Thank god for ppk but a solution really needs to be found. Is the issue with dji or Emlid?

I ran into that about a year ago, ended up being firmware on the M300. I do run into issue with the RS2+ not having a strong enough cell signal a lot. Hooking to my hotspot usually fixes that…weird same carrier same spot sometimes it’s just can’t cut it.

1 Like

Hi Ian,

What is the coordinate system of your base position? Please share a screenshot from the Base settings tab from Emlid Flow. You can send it via PM to keep the data private.

Hi, we convert the co-ordinates from OSBG to WGS. PM sent

Hi there,

Just wanted to say that we’ve investigated this with Ian via PM. The reason for the issue was the coordinates of the base in the Base settings tab. Once we set the correct geographic coordinates, everything started to work well.


A very polite way to say the problem was user error, We are all guilty at some point! Glad it is resolved.


There is no doubt in this! Even people with hundreds and thousands of maps get a brain glitch every now and then. I think many of us experienced this same behaviour with the Emlid receivers when manually entering a coordinate that was too far from where the receiver naturally thought it was. I still don’t know what that tolerance is…

1 Like

Yes, user error and thanks to Emlid for resolving it with me.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.