Disable mavlink


I am trying to do the APM intergration. The problem is that I can’t figure out how to disable mavlink connection to do the Configuring radio for embedding corrections into telemetry.

In emlid docs they said:

"Radio configuration is done with telemetry disconnected.

To change radio settings, make sure Mavlink connection is disabled. Then, go to Initial setup menu, and select Sik Radio in the side menu. Click Load settings and wait for the parameters of both radios to load."

Does anybody know how to disable mavlink connection to make this wok?
Now I get two errors : “failed to enter command mode” and “invalid comport in use”

Thanks in advance

This is very easy to fix.

When you start the mission planner you make sure you have the right baud rate and port number. You connect to your APM flight controller to make sure you have right baud rate and port.
Then you disconnect the APM from Mission Planner and this will disconnect the telemetry.

Now when you connect the 3Dr radios the port will not be busy and you will be able to connect to the radios.

Be care full not to change the baud rate on the radios. If you do change the baud rate you will need to change the baud rate for the Mission Planner so it’s the same as you have set the baud rate for the radios.


1 Like

FYI: you can disable Mavlink from the command line over an ssh connection to Reach.

Neither the documentation, nor your explanation is clear :frowning:
No step-by-step actions to follow.

The step-by-step actions are provided at the link I gave above. What is the problem you are having?

I figured it out

Thanks for your post.