Deciphering GGA string for Foerster Ferex 4.034 Magnetometer

Hello Emlid Community -

I’m taking a big step to connect my Reach RS RTK system to a Foerster Ferex 4.034 Magnetic Gradiometer system but am not having much luck getting it to recognize the NMEA string.

I am connected to the Ferex datalogger through the serial interface on the Reach Rover, connected to the serial interface on the data logger. I’ve checked the GPS status on the data logger and do see data coming through including the occasional $GPGGA… GGA string. But when I check the GPS position information, it’s blank.

I can use some pre-set NMEA drivers (Leica and Trimble GGAs among them) on the data logger or define my own. Since I couldn’t get any of the pre-set drivers to work, I tried to program the Emlid’s string but still can’t get it to work.

The NMEA Driver fields that are required are (I’ve added those field values that I’ve figured out in scouring the forum in parentheses):
Name (Just for Menu ID; I went with “Emlid Reach”),
GPS Manufacturer (Just for Menu ID; I went with, “Emlid”)
Comment (Just for Menu ID; I left blank)
NMEA Message (“GGA”) - Should this one be $GPGGA?
FIX-ID (Don’t know this one)
FLOAT-ID (Don’t know this one)
Pos. Latitude (02)
Pos. Lat./Direction (03)
Pos. Longitude (04)
Pos. Long./Direction (05)
Pos. GPS Quality (06)
Pos. No. Satellites (07)
Pos. DOP (08)
Pos. Height (09)

With a specific interest in identifying the NMEA FIX and FLOAT IDs but also confirming that I’ve set the parameters properly, is there some other setting that might be messing things up? For instance, a NMEA delay? There’s also an option to require PPS for recording. Would that affect things?

Any help would be greatly appreciated.

Thank you everyone!

Hi Mason,

Did you try GNGGA?

Thanks for getting back to me! I did, actually and didn’t have success.

The best I could get was intermittent “Fix” followed by “Bad” GPS icons on the data logger.

I talked to tech support at Foerster (both in Pennsylvania and all the way out in Germany) and did find the answer to the issue, albeit a disappointing one. The Ferex can only read the GGA string but it can’t ignore the non-gga information that’s coming through as well. So that is being interpreted as bad GPS data on the Foerster.

Having read through the forums, I have seen a few posts that specified that you can’t turn on/off specific data strings in the serial output, so from what I can tell, I’m pretty much out of luck.

Unless I’m missing some option in there somewhere that I could do that, I’ll just have to chock it up to a learning experience and heartily request that that functionality is added to the units at some point in the future.

Thank you.

Hi @mmiller,

Thank you for your request!
In the meantime, we don’t have plans on adding this feature. However, your suggestion is noted.

Usually, devices inputting NMEA string (such as for example, GSSI or Sensors & Software devices) are able to filter it and take required messages.

If you really want to get it working, you could always implement a single board computer to read the NMEA sentences from Reach, scrub the ones you don’t want, and then push the cleaned output to your Foerster.

Maybe use a Raspberry Pi Zero or something along those lines.

I understand completely. I had hoped that would have been how things would have worked but it didn’t. If something like that were to come along, it might be pretty helpful but maybe Foerster could work on their firmware, too, to allow the full stream to be acceptable.
Thank you.

1 Like

I’d wondered if there might be some additional hardware solution to do something like that. I wouldn’t have the faintest idea how do go about doing that, but it’s worth checking. In the meantime, I suppose if I need to use that system again, I’ll just rely on rentals where I can turn off/on NMEA strings, I suppose. The Foerster system was compatible with the usual suspects (Trimble, Leica, etc.) so that might be the most expedient solution for now.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.