Data out through serial (DB9 or RS232)

I am trying to set up my Reach RS+ to send the data/position out via the serial cable. I can not seem to get any data out. I have tried as many of the settings in the position out section of reachview as I can find and nothing seems to be coming out.

Clay:

Please give as much information as you can. What is your set up? What are you hooking the
Reach RS+ up to? Do you have a “terminal” or a “tty” type display, which can simply display the ASCII characters as they are transmitted? Are you set up for NMEA 0183 output?
If you’re using the circular LEMO-like connector to the DB9, have you tried reversing the “transmit-data” and “receive-data” wires? Do you have access to a scope or other equipment so you can see if the transmit data line is switching on and off as expected?

From my own experience, problems with getting RS232 output is often due to pinout of connectors, as the pinouts between different makers can vary. In some older equipment, hardware handshaking often becomes a problem, and in the old days, we had to wire “null-modems” between equipment, which patches together the hardware handshaking lines, and reversed the transmit/receive lines.

There are a lot of people willing to help, if you can get enough information to help.

  • tj.
1 Like

I use this to get data to my Mesa2 and FieldGenius . Serial to uart

tj.

The attached pictures should show all the settings I have tried. My ideal goal is to get the position data to come out of the RS+ via the circular connector on the bottom through a female DB9 connector to an AMAN bluetooth NMEA communicator to connect to my iPad using SST (Proagrica) Sirrus. I have tried an off the shelf null-modem but had no luck. I am not the most savy person at “custom wiring” devices. I have also included a picture of my ideal setup.

I just tried on my setup and it works with FG but in reachview it says No Info ??

**

Is there a reason why you aren’t just using the native Bluetooth output of Reach RS+? It doesn’t seem like a RS232 --> Bluetooth adapter is necessary unless distance is an issue.


edit: After a closer look at the picture, I see it is a long-range bluetooth adapter. And I think I found the problem:

https://www.gpsworld.com/aman-enterprises-launches-ios-bluetooth-adapter-to-connect-gnss-receivers-to-iphone-ipad/

So it is an older unit, and in the text there it says that it needs the legacy GP style NMEA messages (GPS constellation only), where Reach outputs GN style messages (multiple satellite constellations).

An alternative wired solution would be to get an adapter for the iPad that gets you a USB port, then a USB-serial adapter. You could plug the RS cable into that.

Or you could try using plugging Reach directly into the iPad USB adapter.

Another possible solution is that you could put a single-board computer in line to read the GN messages and then output ‘fake’ the GP messages to satisfy the AMAN unit.

2 Likes

bide

I have tried connecting the serial cable to a usb to serial adapter on a laptop and still have had not luck getting position information. I was using Farm Works SiteMate for the program to receive the data.

Clay

Can you try another program like hyperterminal or something simple that just show you the serial port output?

Are you using the Emlid RS cable? Do you have any other adapters inline, such as a gender-changer? Do your baud rate settings match between ReachView and the laptop?

I do not have any other software that I can try it on. I am using a cable from Emlid with no gender changer. The baud rates do match. I have tried a null modem just so see if that was the problem but no luck.

OK for troubleshooting there are 3 things left:

  1. give us a screenshot of your ReachView position output settings so we can make sure it is right

  2. find a way to detect output on the serial cable. Maybe tell us what O/S is on your laptop and someone can suggest a free program to monitor the information coming in the serial port.

  3. find out if the program you are trying to use will accept the contemporary GN style NMEA messages or if it also only recognizes the legacy GP style NMEA messages

2 Likes

Hi @Clay,

Have you tried @bide’s recommendations? What is the result?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.