CS20 -> Field genius -> RS2 Bluetooth connection failure

Hi everyone,
It would be great if anyone has some ideas on how to fix an issue I am having.

Leica CS20 4.10 using Micro survey Field genius
RS2 V2.24.2

I had a stable setup, bluetooth to the RS2 from in field genius on the CS20. I have a SIM card on the CS20 with stable internet connection that field genius recognises OK.

For no apparent reason I was unable to receive corrections through field genius one day in the field. Field genius showing ‘no updates’ from correction service, I had stable internet, RS2 could receive corrections if tethered to phone using same credentials and mount point. I tried few basic things that did not fix it.

I updated to the latest reach2 firmware just in case that would help.

result= Can no longer connect Bluetooth through the field genius app to the RS2. I have tried everything I can think of.

From within field genius, it recognizes the RS2, but when I connect to it, it gives an error to check the device or PIN. I can connect to the RS2 through my laptop OK. I can also connect to RS2 from the CS20 on the winCE native bluetooth. It seems to be field genius with the RS2 is failing for some reason.

I originally had these issues a month or so ago when I first tried FG with the RS2 but somehow it started working and I can’t remember what if anything i did?

Does anyone have any ideas on how to resolve this?

Thank you,

What OS is the CS20 using ?

It is winCE v7.0 (build 2864)

CS20 firmware V4.10

Did it just quit working all of the sudden or did it never work?

I had it working for a couple of weeks but initially I had the same bluetooth issue. I can’t remember if i did anything to fix it, or it just started working.

Now, it was connecting ok, then I updated RS2 firmware to latest then it is not connecting again.

I am wondering if there is any setting on the RS2 that has been changed from the update, that fieldgenius is not liking?

Are your Bluetooth corrections set to EBR or NMEA?

I resolved the issues. Below are the details in case it helps someone else.

  1. the Bluetooth connection issue.
    I went into Lecia captivate on the CS20 and changed the connection to our total station from “Long range bluetooth” to “Cable” so it is not looking for a total station in leica captivate using bluetooth.

By doing this it modified some settings on the WinCE network settings. I am not sure exactly what it did, but the result is that it now allows Fieldgenius to connect to the RS2 over bluetooth.

  1. Corrections update issue.
    I had the wrong settings on the RS2 unit. I had to set the corrections input tab to “bluetooth”

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.