Crash after autotakeoff!

hi guys!
After a few flights today i tried out auto take-off;
I uploaded a mission, armed the copter, switched to “auto” and raised the throttle; copter took off and flew in a strange direction; i checked the mission on the laptop, rechecked; seemed wrong; tried to switch to rtl - didn’t change the direction (things went quite fast and trees were not far away)
i don’t have a lot of experience with checking logfiles, but this looks wrong to me:


can anyone tell me if this was a hard/software bug or my mistake?

here is the logfile
https://drive.google.com/file/d/0B9PqIZ8f2EDsTzZkZ2F3UmNNcmM/view?usp=sharing

Thanks, Benedikt

PS: GCS is controlled via LTE; also Controls are made via Taranis RC and x8r receiver (actually i mainly use the taranis for flightmode changing or - of course - manual flight)

Have you screwed the board down? It seems like somehow autopilot didn’t get fed with new accel/gyro/mag values for quite some time. The only reasonable answer I may provide right now is the disconnection of the board during a flight. This also may be a result of vibrations.

the board is screwed down with plastic screws and wrapped into heatshrink, so i can’t really see if there’s the possibility of a loose connection - but screws are plastic - so disconnection is definitely a possibility;
I will unwrap it and have a closer look and do a follow up;


(“the cable monster”)

By the way:
Would the esc’s turn off the motors, if I reboot the pi over ssh as a kind of emergency shutdown, or would the chip on Navio2 keep his state as long as he has power?

thanks for your effort @george.staroselskiy !

If you reboot your Pi, the ESCs don’t get new PWM values. So no worries here, the motors will be turned off.

We’ll be looking into the issue. I hope your hardware didn’t get damaged during the crash.

1 Like

thx;
Hardware is 100% fine - except the 3d printed legs (a few cents) - so no lost! a tree grabbed the drone safely!

I checked Navio2-RPI3 connection; I don’t really see a high probability that the connection did become loose - it is very tight and no gaps visible;
I rechecked the logs and if i uncheck the “use time” ticker, i get a different graph (not sure what that means):

PS: this is the video from the flight; the take-off and crash is at the end!
https://youtu.be/t-ZdkaI0CIg (hope it works though its marked as “private”)

Unfortunately, the video is indeed private. That’s why we cannot access it :frowning:

Changed it to unlisted!

I finally found the logfile from the tower-android app;

(relevant time starts at about 91% of the logfile)
https://drive.google.com/open?id=0B9PqIZ8f2EDsdkRmYjZxZFdwNlk

immediately after arming compass went crazy…(it seems to be dependent from the current flow)
but I don’t know why - didn’t change anything from the flight before - (except adding a voltage indicator on the balancer plug )

PS:
I also added a Y-Splitter cable (because I use 2x 4s16Ah Lihv) to observe both batteries…I believe there is a relevant current flow throught that Y-cable from one battery to the other…that cable wasn’t very far away from Navio - about 15cm;
I strongly suggest that caused the compass problem…and the compass problem caused the copter to fly in the wrong direction to reach the waypoint…