Converting UBX to Rinex for processing through opus

I am having issues with my new RS2 as far as post processing goes. I am attempting to just occupy in single point for 30min then take the data into RTKConv to export the rinex files so I can send it to OPUS and get a solution. I have done so with Trimble and Leica products with little issue before but am new to the Emlid products. I do not have an additional post processing program to use and is as of right now my biggest hindrance I think.

Simple system report
app version: 2.20.7-rs2-rc0-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip:
  is_added: true
  is_connected: true
  is_visible: false
  mac_address: 6C:21:A2:8F:A3:8E
  security: wpa-psk
  ssid: exede-6846_2GEXT
  uuid: 4b5a3396-55d5-4ea9-b9a2-29e1c8de4055
base mode:
  base coordinates:
    accumulation: '30'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
    enabled: false
    format: rtcm3
    path: lora
    type: lora
  rtcm3 messages:
      enabled: true
      frequency: '0.1'
      enabled: true
      frequency: '1'
      enabled: true
      frequency: '1'
      enabled: true
      frequency: '1'
      enabled: false
      frequency: '1'
  discoverable: true
  enabled: true
  pin: '***'
correction input:
    enabled: false
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
    format: RTCM3
    started: false
    version: null
    format: RTCM3
    started: true
    version: null
  interval: '24'
  overwrite: false
    format: UBX
    started: true
    version: null
    format: LLH
    started: true
    version: null
  air rate: '9.11'
  frequency: 868000
  mode: write
  output power: '20'
position output:
    enabled: false
    format: nmea
    path: bluetooth
    type: bluetooth
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: static
  positioning systems:
    compass: false
    galileo: true
    glonass: false
    gps: true
    qzss: false
  snr mask: '35'
  update rate: '5'

Use RTKConv for the conversion. Works like a charm.

1 Like

Hi @jeff,

Could you please clarify your difficulties with converting to RINEX in RTKConv so we can help you to figure it out?

I’ve checked your system report, and it seems you set up the 5Hz update rate. As far as I know, OPUS accepts data logged with 1Hz and lower frequencies, so I recommend changing the update rate to 1 Hz and trying to record the data once again.

Hi Tatiana, currently I have been getting my rinex files refused to be processed because of single frequency data. Does rtkconv use both l1/l2 in the conversion because it seems that I’m not getting fuel frequency into my rinex .obs files.

Thank you

Yes I am using RTKConv to create the Rinex file but for some reason OPUS is kicking the file saying it is single frequency and dual frequency is required.

Thank You,
Jeff Biggs

i maybe wrong since i dont own a RS2, but based on what i see it supports L2C not L2

if your successful with processing RS2 data with OPUS i really would like to hear about it. I use OPUS with a standard GPS l1/l2 receiver (just as you appear to have done). to my knowledge OPUS requires l1/l2 and does not yet do L2C since L2C is still pre-operational (aka beta) .

I think that is a pretty old link, my rinex 2.11 files just list L2 no L2C. I thought it used to cause problems when L2C first came out but that was with the rinex converter software, later updates fixed it so that as the L2 legacy signals die off nothing has to be done to receivers to transition to L2C

Hi Jeff,

Do you use the correct RTKLib version from our docs for converting RS2 log files? Please note that there are 2 of them: one for L1 Reach receivers, and one for Reach RS2.

Please also share the screenshot of your RTKConv settings.

Hi Tatiana,
I am using the RS2 version of RTKLib, I have not had the time to try the 1hz recording as of yet I have been super busy with other things but will try it out soon. here is a screen shot of the RTKLib I am using for conversion. Also I have tried to change the interval to 30s but when I do I do not receive any .obs file. I know the opus prefers to have the epochs and a certain rate of 1 to 30s.

Thank You,
Jeff Biggs

Question; why are you converting UBX files to Rinex, rather than simply logging Rinex files to begin with? (On the logging page, (Raw data) select file type) Now, having asked this, i too am getting the response from OPUS that it requires two frequency data files, and that the Rinex file i uploaded from my RS2 seems to be only single frequency. Any ideas?

@jeff The checkbox for enabling L2 is found by clicking the “Options” button in the screenshot above. That options screen was the requested screenshot.

the only thing I can think of offhand would be that you didn’t have the L2 box checked in the options menu if you ran the files through RTKConv.

Here is the screen shot of the options window. I am running another attempt this afternoon haven’t had the time lately will let you know the results.

Thanks Jeff

1 Like

This is the latest error message I am getting so at least Im making progress.

6029 After the single baseline analysis, fewer than 3 useable

  • 6029 reference stations remain. Aborting.*

No, i didn’t use RTKCONV, i saved the files as Rinex 3.X within the RS2, under the logging file options.

I tried to use the rinex files output by the RS2 and opus would not accept it but if I did run it through RTKCONV it would accept them but I still get the error in baseline etc.

Hmm, ok, i’ll try that…

Well, I tried to RTKconv, then upload to OPUS, now i get

“1021 The year and day-of-year could not be determined from the submitted data set.
1021 The data set may be corrupt. OPUS can not continue the processing.
1021 Aborting…

I use rinex 2.11 from the rs2 and they go right through opus static, L1 L2 1 hour data collection.

1 Like

Interesting, I’ll Give it a try!