Converting Reach .log file to Rinex

Continuing the discussion from Not able to convert Reach log to Rinex:

@igor.vereninov, I’ve got a similar situation. Just took the reach unit outside and logged a ~1MB .log file. Tried to convert and got the following error:

Any ideas? I can email you the file if you like. I’m running this version of RTK lib,

which from the last post should work? Let me know!

Also, here’s what my config looks like in the Reach View app:

1 Like


You need to set Format to “u-blox”.

After doing that, it worked perfectly. You would think that @tomoji_takasu would have made it such that selecting “auto” in RTKConv.exe automagically determines the file type that is loaded. Its probably a super low priority bug. I’ve converted the raw data to Rinex .obs files using RTKConv.exe. Then I post processed the data with ground based correction sites in GrafNav (made by NovaTel) here’s what it looks like:

Doing this gave me approx the following standard deviations:

East 0.017m
North 0.007m
Height 0.011m

Note that these must be post processed to get this type of accuracy, but for what I am doing with these units that works fine for me.

Thanks @ivereninov for your help! Hopefully at some point we can flash the Reach unit that will directly output a Rinex file, but for now the process of converting it using RTKConv.exe works for me!

Jeremy, very soon you will be getting Rinex straight from the Reach, so this should not be an issue any more.

Really appreciate you posting your results here :+1:


Did we ever get Rinex output into the new Reach firmware? Thought I’d check before blindly downloading and installing.


Jeremy, already there. Just hit “update” in Reachview.

I’m assuming that these are image files because this one and the previous one I got are identical file sizes. The previous one I had installed was also called v1.2. Is there a v1.3, or did the changes get in but the name didn’t change?

To get Rinex logging you do not need to reflash the device, just make the update within the app. Go to the tab with gear icon and press “update” button. Your Reach should be connected to internet to perform the update.

Dumb Question:

Where do you enable Rinex logging? I don’t see an option for that here:

And under logs all I’m getting is:

Just click on that log file :wink: If it has any valid data inside it will be converted to Rinex.

Did that, but it never actually starts downloading. It just says “your download will begin shortly”.

Have you been able to resolve the issue/download the log? Maybe a restart could help?

What version of ReachView are you using?

I have not resolved the issue. Essentially the .ubx file is formed while logging. I click on the file to download it. It then says “converting to rinex, waiting X seconds.” Next it says “your download will start shortly”. Then it never downloads the file. It also (by looking in the /home/reach/logs directory) never creates the Rinex file (at least not there). Not sure where else the Rinex would be stored. The file just never downloads either. I’m using ReachView version 0.1.0.

One of modules is doing this too. See my post here - Reflashed module won't create RINEX file for download.

This should be solved by updating

This was solved by updating. As stated above. I had a another related question though. Is it possible for Reach to boot and start logging without a ReachView connection? It seems like one unit I have boots and flashes yellow (looking for a network connection) and wont do anything else until it finds one.

The other one stays magenta unless I have a hotspot active for it to connect to.

Ideally, I’d like to plug them in and remember their previous state (“Started”) and start logging on power up.


They actually do remember the state you leave them in. Yellow flashing LED should not last more than 20 seconds. Can you confirm this?

Never mind my previous comment. The unit is actually flashing orange, that means it needs to set system time to function properly. This is done by connecting Reach to an antenna and letting it get the time via GPS, or connecting it to the internet. More on this here.

Thank you for your quick reply! Makes perfect sense! As I was testing the unit indoors just to make sure it boots. Wanted to make sure if I handed it off to someone that didn’t know have the knowledge to connect over wifi to the unit that it would fully boot. I was wondering also (sorry for endless questions!) if there was documentation of all possible states of the LED lights? I was going to tape a tiny copy of it to the unit for others for future reference. I tried looking through the forums but didn’t find a bulleted list of info like:

Orange: Waiting for system time, through either GPS or WiFi
Green: GPS OK
Magneta: X. y z ect…

Let me know if this already exists somewhere.