Converting Raw Rover .ubx files to Rinex failing

Hi everyone,

I got back from my first survey with the Reach RS today, and am going through the procedure for post processing as a test. I am using RTKLib to convert the .ubx files from the rover to Rinex, but I am not getting any outputs. I am following the guide found here : https://docs.emlid.com/reach/common/tutorials/gps-post-processing/

I am a little confused as I AM able to convert the base .RTCM file into Rinex, and obtain the .obv and .nav that I want.

The only thing I see different between my windows and the tutorial document is that I am not able to select RINEX 3.3. Mine only goes up to 3.2.

Does anyone have any suggestions to remedy this problem?

In the future, I plan on setting my logs to record as Rinex from the outset. Are there any disadvantages to doing so?

You convert .ubx to U-BLOX in the RTKCONV application. Are able to do that?

Thanks for replying.

That is the stage I am stuck on. When I input my .ubx file, and select U-BLOX as the output format, nothing seems to happen after I push Convert.

Could you post the raw .ubx your are trying to convert?

Please download RTKCONV from our docs:

https://docs.emlid.com/reachrs/common/tutorials/gps-post-processing/

This solved the problem. Thanks!

1 Like

Hi guys,

Just wanted to share a couple of updates for this thread. Now, to convert files from UBX to RINEX, you can use the Emlid Studio app. We tried to make the app intuitive and easy to use. But all the conversion steps are also described in this guide from Emlid Studio docs. Feel free to try it!