Continued problems with RS2+ wifi connectivity in Flow

I have updated to the latest FW and I was happy to read it was supposed to help with wifi connectivity. But I have continued to have problems with my Rover while surveying points. It looses connectivity often in the app. I will have to go back to “Receivers” and then click on refresh. Then the rover will show up and I can continue the survey.

Yesterday after my survey, I connected the RS2+ rover to a wifi router so that I can do local ntrip with my M3E. But after I finished the flight I powered down the wifi router and finished doing other work. I could no longer connect back to the RS2+ to stop logging and and shut it down via the app.

I actually wanted to survey one more target but I could not connect to the RS2+ (I always use my iphone) and it did not show up as an available Wifi connection. So I just had to power down the RS2+ using the power button.

I have an Inertial Labs Lidar unit that I stay connected with when doing mobile lidar missions and never have any connectivity problems. So it is not my phone. There has got to be something wrong with the RS2+ or the firmware that is causing this behaviour.

Is anyone else having this problem when doing surveys?

This problem seems to be more prevalent when I turn off the screen to put the phone in my vest pocket. Yesterday I drove around doing a bunch of topo shots and it never lost connectivity. The app stayed active on my phone sitting on the console as I drove around a large field taking topo shots. So not sure if this is happening due to the screen being turned off?? I do that to prevent any unwanted actions happening on my phone.

Hi, did it revert to Emlid’s RS2+ hotspot mode after discontinuing the Wi-Fi Router Hotspot?
If it was in Emlid’s hotspot (steady white LED) mode, I can see why it would not see your phone’s Wi-Fi connection without your phone’s Wi-Fi pointed to the Emlid’s hotspot.
You would have most likely had to reboot the Emlid unit in order for it to discover your phones Wi-Fi hotspot connection.

After rebooting the RS2+ did it see your phone’s Wi-Fi Hotspot?

Hi Mark, I was not trying to connect the RS2+ to my iphone hotspot, but merely trying to connect my iphone to the RS2+ hotspot. After turning off the Wifi router, the RS2+ should have reverted to the Emlid hotspot being available. But it never did. This is no doubt some type of FW issue. I think the way to prevent this is to tell the RS2+ to enable the local hotspot in Flow before powering down what ever wifi device the RS2+ is connected to.

It is ashame that you can not do everything to manage the RS2 using bluetooth. Only some functions are available via bluetooth. Not sure why that is. Logging is one of them.

Hi Tim, ok, that makes better sense, the Emlid receiver did not fallback to it’s own hotspot after disconnection to the Wi-Fi hotspot. Thereby allowing your phone to connect to it without having to reboot the RS2+ receiver. Did you happen to try and restart the receiver to see if your phone would allow a connection to the receiver’s hotspot?

Hi Tim,

We’ve released some Wi-Fi connection fixes in the latest 31.1 firmware version. Please update the receiver and let us know how it works for you.

If it doesn’t help, please test if it’s possible to connect to the device in the hotspot mode via its IP address You need to input it in the browser address bar. It’ll possibly show whether the issue comes from the receiver or the app side.

I am running the latest FW. I was hoping that would fix the problem. If no one else is having this problem then maybe I have a defective unit. I have been using the RS units since I had the RS+ years ago, then RS2 and now RS2+. So I am very familiar with the units.

I will start tying the browser instead of Emlid Flow and see if that improves things. Don’t see how it can but I will try it.


I had to go and did not have time to mess with it in the field. Once it was powered back on in the office, yes I could connect to it (but that is always is the case).

There are other problems on every job. I have SIM cards in both units. Often there is data connectivity but the screen shows the mobile data is OFF. If I touch it to turn it on, it does not actually change to blue but yet I will have connectivity. Yesterday I did have to reboot the Base unit and after rebooting it the mobile data began to work (even though the blue light was never on)

So now on every job, even when I am setting up the base on a known point, I turn on RTK to make sure data is flowing in so that I know that mobile data is working so I can do RTK on my Rover. I used to just check the caster website, but recently I could be connected and sending out corrections and yet the Caster site shows offline for the base.

If no one else is having multiple little issues then hooray for them. It seems that the RS2+ has plagued me with repeated little issues. I can work thru them but there is never a day when everything works flawlessly so that I can simply do what I need to do.


I was incorrect. I only had 31 and not 31.1 :blush: I am updating now. Will let you know if that fixes the problem.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.