Connection problem with Navio2 and Qgroundcontrol

when ı wrote this code ı got this output

[ INFO] [1565015589.672727951]: Plugin imu loaded │pi@navio:~ $ roscore
[ INFO] [1565015589.719459641]: Plugin imu initialized │… logging to /home/pi/.ros/log/a83ce30c-b78d-11e9-8a32-b
[ INFO] [1565015589.720102665]: Plugin local_position load│827eb64b83c/roslaunch-navio-908.log
ed │Checking log directory for disk usage. This may take awhil
[ INFO] [1565015589.763343348]: Plugin local_position init│e.
ialized │Press Ctrl-C to interrupt
[ INFO] [1565015589.764018300]: Plugin manual_control load│Done checking log file disk usage. Usage is <1GB.
ed │
[ INFO] [1565015589.790125408]: Plugin manual_control init│started roslaunch server http://navio:33789/
ialized │ros_comm version 1.12.14
[ INFO] [1565015589.790817235]: Plugin param loaded │
[ INFO] [1565015589.813056251]: Plugin param initialized │
[ INFO] [1565015589.813747505]: Plugin rc_io loaded │SUMMARY
[ INFO] [1565015589.843533798]: Plugin rc_io initialized │========
[ INFO] [1565015589.844156197]: Plugin safety_area loaded │
[ INFO] [1565015589.876231669]: Plugin safety_area initial│PARAMETERS
ized │ * /rosdistro: kinetic
[ INFO] [1565015589.876943964]: Plugin setpoint_accel load│ * /rosversion: 1.12.14
ed │
[ INFO] [1565015589.904143630]: Plugin setpoint_accel init│NODES
ialized │
[ INFO] [1565015589.904928582]: Plugin setpoint_attitude l│auto-starting new master
oaded │process[master]: started with pid [919]
[ INFO] [1565015589.974952835]: Plugin setpoint_attitude i│ROS_MASTER_URI=http://navio:11311/
nitialized │
[ INFO] [1565015589.975707370]: Plugin setpoint_position l│setting /run_id to a83ce30c-b78d-11e9-8a32-b827eb64b83c
oaded │process[rosout-1]: started with pid [932]
[ INFO] [1565015590.084946393]: Plugin setpoint_position i│started core service [/rosout]
nitialized │
[ INFO] [1565015590.085808480]: Plugin setpoint_raw loaded│
[ INFO] [1565015590.163810108]: Plugin setpoint_raw initia│
lized │
[ INFO] [1565015590.164624956]: Plugin setpoint_velocity l│
oaded │
[ INFO] [1565015590.215477755]: Plugin setpoint_velocity i│
nitialized │
[ INFO] [1565015590.216182393]: Plugin sys_status loaded │
[ INFO] [1565015590.291826145]: Plugin sys_status initiali│
zed │
[ INFO] [1565015590.292733858]: Plugin sys_time loaded │
[ INFO] [1565015590.335739431]: TM: Timesync mode: MAVLINK│
[ INFO] [1565015590.345560729]: Plugin sys_time initialize│
d │
[ INFO] [1565015590.346002658]: Plugin vfr_hud loaded │
[ INFO] [1565015590.351491174]: Plugin vfr_hud initialized│
[ INFO] [1565015590.351959874]: Plugin waypoint loaded │
[ INFO] [1565015590.382587679]: Plugin waypoint initialize│
d │
[ INFO] [1565015590.383048879]: Plugin wind_estimation loa│
ded │
[ INFO] [1565015590.388478281]: Plugin wind_estimation ini│
tialized │
[ INFO] [1565015590.388751251]: Built-in SIMD instructions│
: None │
[ INFO] [1565015590.388845834]: Built-in MAVLink package v│
ersion: 2019.7.7 │
[ INFO] [1565015590.388950470]: Known MAVLink dialects: co│
mmon ardupilotmega ASLUAV autoquad icarous matrixpilot pap│
arazzi slugs standard uAvionix ualberta │
[ INFO] [1565015590.389034429]: MAVROS started. MY ID 1.24│
0, TARGET ID 1.1

stop there and ı haven’t connected qgroundcontrol could you help me please ?

NOTE :
ı modify my IP in /etc/default/arducopter
like that TELEM1="-A udp:192.168.1.56:14550"
after sudo systemctl daemon-reload
and sudo emlidtool restart arducopter
ı did these

Hi @EmreEngin,

The next step after running roscore is running ardupilot. In TELEM options you should specify localhost IP: TELEM1="-A udp:127.0.0.1:14650".

By running a mavros node you can connect to your GCS. The command running mavros:
rosrun mavros mavros_node \
_fcu_url:=udp://:14650@ \
_gcs_url:=udp://:14551@x.x.x.x:14550

, where x.x.x.x is the IP of your computer with GCS.

Following this link, you can find our tutorial on how to launch ROS on Navio2.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.