Connection Problem RTK Ardupilot İntegration

  1. Firmware image and ReachView version: V2.20.8
  2. [System report]
Simple system report
app version: 2.20.8-r0
'wifi_status, interface: wlan0':
- wifi_mode: wpa_supplicant
- ip: 10.15.16.26
  is_connected: true
  mac_address: fc:db:b3:92:d4:30
  ssid: Gokturk_wifi
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: false
    format: rtcm3
    path: serial://ttyMFD2:57600:8:n:1:off#rtcm3
    type: serial
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
camera:
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
position output:
  output1:
    enabled: true
    format: erb
    path: ttyMFD2:38400:8:n:1:off
    type: serial
  output2:
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzss: false
    sbas: true
  snr mask: '15'
  update rate: '5'

Hello ,

I’ve been using your rtk kit for a while. I didn’t have any problems during the first test flights.
I’m having trouble connecting to Reach. It didn’t turn on and it turned on and off as I understood from its lights (repeatedly repeating).
I flashed it again and installed the latest version.
I could not re-establish the Rtk connection.
The settings for arduplane, base and rover are as follows.

Arduplane setting:

image.png

Reach:

image.png

Reach rs:

image.png

Connection screen :

image.png

I use for this Rfd868x and set parameters Raw Data and clear ecc field.

image.png

Also try for connect over wifi (between Reach RS and Reach )

Connection running stable

Reach screen after connection.

image.png

image.png

image.png

Although GPS 2 is detected and position is sent, rtk correction is not transmitted on Reach
I need your immediate assistance to resolve this. How to debug it?

Thanks for your help

Hi Kadir,

It seems I’ve already answered to your email. However, I duplicate it here so other users can join the discussion and advise anything useful.

First, may I ask you to share your hardware setup photos so I can check if Reach is connected correctly to the flight controller?

Also, I’d like to ask you to update images in your first post as they can’t be loaded.

Thanks.

I checked the Tx and Rx pins and connected them with the cable that came with the Pixhawk.

Now I use Telem2 Port on Pixhawk
The result has not changed
GPS connection available, reach sends coordinates to autopilot, but correction data is not transmitted to reach.

Hi Kadir,

I checked all the screenshots you sent me in the email once again and it looks like everything is configured properly.

I assume there is might be an issue with wires. Is there any chance you have got another cable to test with it?

The cable in the photos I took was new. I got the same result as the previous cable

Hi Kadir,

We’ll try to replicate your setup to check where the issue might appear.

Hi Kadir,

I’ve tried to reproduce your setup. May I ask you to change the following configurations:

  1. Use GPS2 port instead of TELEM2 on Pixhawk.
  2. Change GPS_TYPE2 parameter in the MissionPlanner from “1” - AUTO to “13” - ERB.

Let me know if it helps.

Hi Gleb ,

I tryed your suggestion .Changed port and type , status did not change.
I suspect the socket with the rx tx pins on the reach.
Is there a way to verify that correction received by reach ? Using ssh to access edison terminal ?

You may want to try an power reach from a separate bec I have noticed they are quite sensitive to power fluctuations many of those ports on the pixhawk cannot support large loads. telem 1 is its own 1amp circuit the rest share 1amp.

Hi Kadir,

May I ask you to send System Reports for both Base and Rover?

Also, could you you please take a screenshot of incoming base corrections in the MissionPlanner?

Hi Gleb,

I run the system, made all the connections, and I got the reports.

ReachRS log;

Simple system report
app version: 2.20.8-r0
'wifi_status, interface: wlan0':
- wifi_mode: wpa_supplicant
- ip: 192.168.10.100
  is_connected: true
  mac_address: fc:db:b3:95:e4:71
  ssid: Gokturk_wifi
base mode:
  base coordinates:
    accumulation: '1'
    antenna offset:
      east: '0'
      north: '0'
      up: '1.48'
    coordinates:
    - '37.86565182'
    - '32.41805361'
    - '1200.945'
    format: llh
    mode: float-and-hold
  output:
    enabled: true
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '1'
    '1008':
      enabled: true
      frequency: '5'
    '1010':
      enabled: true
      frequency: '1'
    '1019':
      enabled: true
      frequency: '5'
    '1020':
      enabled: true
      frequency: '5'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
    gps:
      enabled: false
      frequency: '1'
    qzss:
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: K104200201:***@212.156.70.42:2101/VRSRTCM31
    send position to base: single
    type: ntripcli
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
lora:
  air rate: 2.6000000000000001
  frequency: 868000
  output power: 20
position output:
  output1:
    enabled: true
    format: erb
    path: ttyMFD2:57600:8:n:1:off
    type: serial
  output2:
    enabled: false
    format: llh
    path: ttyGS0:115200:8:n:1:off
    type: serial
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzs: true
    qzss: false
    sbas: false
  snr mask: '10'
  update rate: '1'

Reach log;

Simple system report
app version: 2.20.8-r0
'wifi_status, interface: wlan0':
- wifi_mode: wpa_supplicant
- ip: 192.168.10.108
  is_connected: true
  mac_address: fc:db:b3:92:d4:30
  ssid: Gokturk_wifi
base mode:
  base coordinates:
    accumulation: '2'
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - '0'
    - '0'
    - '0'
    format: llh
    mode: single-and-hold
  output:
    enabled: false
    format: rtcm3
    path: serial://ttyMFD2:57600:8:n:1:off#rtcm3
    type: serial
  rtcm3 messages:
    '1002':
      enabled: true
      frequency: '1'
    '1006':
      enabled: true
      frequency: '0.1'
    '1010':
      enabled: true
      frequency: '1'
    '1097':
      enabled: false
      frequency: '1'
    '1107':
      enabled: false
      frequency: '1'
    '1117':
      enabled: false
      frequency: '1'
    '1127':
      enabled: false
      frequency: '1'
bluetooth:
  discoverable: false
  enabled: false
  pin: '***'
camera:
  duty cycle: 20
  enable: false
  period: 2
  polarity: true
correction input:
  input2:
    enabled: true
    format: rtcm3
    path: ttyMFD2:38400:8:n:1:off
    send position to base: 'off'
    type: serial
  input3:
    enabled: false
    format: rtcm3
    path: :9028
    type: tcpsvr
logging:
  base:
    format: RTCM3
    started: true
    version: null
  correction:
    format: RTCM3
    started: true
    version: null
  interval: 24
  overwrite: true
  raw:
    format: UBX
    started: true
    version: null
  solution:
    format: LLH
    started: true
    version: null
position output:
  output1:
    enabled: true
    format: erb
    path: ttyMFD2:38400:8:n:1:off
    type: serial
  output2:
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
  output3:
    enabled: true
    format: llh
    path: :2014
    type: tcpsvr
  output4:
    enabled: true
    format: llh_ext
    path: :2015
    type: tcpsvr
rtk settings:
  elevation mask angle: '15'
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: '1'
  max vertical acceleration: '1'
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: false
    glonass: true
    gps: true
    qzss: false
    sbas: true
  snr mask: '15'
  update rate: '5'

I tested the pins on reach rxpin show this:


Base correction is open, streaming;

Base correction is close, stopped streaming;

Oscilloscope display shows signal. But I don’t know if it’s true.

If there is no other problem, I would like to re-solder the socket’s soldering ways.
What would you think for that?

Hi Kadir,

May I ask you to check the signal on the PixHawk UART TX pin with an oscilloscope? Please send us the photos of the display with enabled/disabled base corrections.

Hi Gleb,
I check your suggestions

Disable corrections;

Enable corrections;

Pixhawk tx pin connected Reach rx and I measure it.

Hi Kadir,

Is it possible to connect your radios directly to Reach RTK and Reach RS? We want to check if your radio module can transfer base corrections.

Hi Gleb,

I did what you said, nothing changed . But today we made a detailed examination on reach and decided to re-solder the circuit paths.
RTK started working without the need for any other operation that gave the result.

Thank you very much for your help. :slightly_smiling_face:
I will also share our recent research on accuracy.

2 Likes