Connection Navio2 To Mission Planner Errors

I am trying to connect the Navio2 to my computer with mission planner. If I use TCP, then it says: No connection could be made because the target machine actively refused it (Ip address). If I use UDP, it says: Only one usage of each socket address is normally permitted. If I change the port from 14550 to something like 14555, then it just tries to connect forever. I have tried through an internet-connected network, as well as connecting ethernet directly from the pc to the pi.

I am using:
Raspi 4b
Navio2
Windows 10 pc

If you think you can help but need more information, please let me know. This is for a school drone team, and I don’t have a lot of time. Any help is appreciated!

Hi Jason,

Welcome to our forum!

Have you tried to disable the firewall on your PC? It might be possible that it prevents the connection with the device.

Also, I’ve found this thread on the ArduPilot forum where the users had a similar issue. I suggest checking out the potential solutions from the thread.