Connection issues Navio+ with APM Planner 2

I’ve just started to set up my Navio+ have successfully established a connection between the board and my laptop (which runs APM Planner 2) via the mobile network. However, the connection does not last very long and the APM Planner stops receiving MAVlink messages after approximately one minute. If I then reconnect using the APM Planner I regain the connection, but only for a another minute or so. I’ve tried establishing the link using both via APM:

sudo ArduPlane -A IPADRESSGC:14550

and via MAVproxy:

sudo ArduPlane -A udp:
sudo --master= --out=IPADRESSGC:14550

both approaches give the same result. I am assuming the autopilot is running continuously since I can regain the connection from the ground station. Does anyone have an idea as to why the APM Planner would randomly stop receiving data?

Also, I am unable to get the MAVproxy ‘console’ to start which could help me troubleshoot this. I get: “Unable to access the X Display, $DISPLAY set properly?” message and yet have not found a fix for this. If anyone has some info about that as well it would be much appreciated!


Search the forum on broadcast redirect via SOCAT. That was the trick used by others to get a stable link when the network disconnects. I also prefer that on private WiFi links as a configuration free way to connect from any GCS. The GSC connects to the drone then, not the other way around (no need to use MAVProxy).

I also wrote some scripts here:

For streaming (over WiFi) but you could take the APM start and broadcast scripts. I got the information from here originally:

Thanks for your reply! As I understand it, using this approach allows the GCS to find the RPi if they are connected to the same Wi-Fi network. The RPi broadcasts to all devices in the same network which allows any GCS within the network to receive the output and connect to the RPi. However, I’m not within the same Wi-Fi network (I’m using a 4G modem), which I’m assuming makes using the RPi as an access point impossible without the public IP address of the modem (which I don’t think is available). I guess that the only possible way to connect is by accessing the static IP of the GCS and not the other way around. Although I’m merely a beginner in communication so I might be wrong. Is this approach still viable for me?

Turns out APM planner was the problem, switched to mission planner and it worked flawlessly.

1 Like