Connecting to SIK Radio

I’m totally new to the subject. I have configured Navio 2 with Pi3 and I can connect the copter to MP through UDP. I connected 915Mz radio. One to Navio through UART. Both unit green led’s are lit and still. I’ve done load settings through SIK radio configuration and everything is fine.But I can’t connect to the radio through MAVLink. I’ve checked serial port communication with /boot/cmdline.txt and it’s fine. But /etc/inittab file is empty.

I’ve tried starting with “sudo arducopter -C /dev/ttyAMA0” in putty and when this is running in putty I can connect to Mission planner from the ground control side to the quad.But if I close putty the connection get lost. Can someone help with this issue.

Hi Chaminda,

Have you gone through this guide?

Have you tried to configure -C /dev/ttyAMA0 in /etc/default/arducopter file?

You can turn on the ardupilot automatic starting after boot via sudo systemctl enable arducopter or you can specify it using emlidtool.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.