Connecting RS3 to RIEGL VZ-400i via Bluetooth

Hi,
I am attempting to connect a Reach RS3 to a RIEGL VZ-400i terrestrial LiDAR scanner to use as an external GNSS antenna. I have the scanner and RS3 connected via Bluetooth, but GNSS data does not transfer to the scanner itself. What baud rate and com(comm) settings does the RS3 require for transferring data? I am able to configure a file for specific GNSS settings on the scanner itself, and I believe these settings are the issue.

Thanks!

Firmware: 31.8
Emlid Flow: v10.0

Hi Tanner,
I am trying to do the same with a RS2+ and a Riegl VZ-2000i (and possibly a RS3 in the near future). If you ever figure this out, please let me know.

Thanks,
Kurt

Hi Tanner,

Welcome to the forum!

We haven’t tested Riegl LiDAR scanners, but I’d like to dig deeper. Can you tell me what your settings are in the Emlid Flow and LiDAR? The screenshots will be appreciated.

There are several ways to stream Reach position: Serial, TCP, and Bluetooth. You don’t need to choose the baud rate or COM in the Emlid Flow while streaming via Bluetooth. Is it possible to stream position via Serial or TCP in your case?

Hi,
I successfully connected the RS3 to the VZ-400i via Bluetooth by using the default settings within the scanner’s provided template GNSS configuration file for Bluetooth connections. COM settings are 0, and Baud rate was the highest possible setting (115200).
Thanks for the help!

1 Like

Hi Tanner,
Is it possible for you to share the contents of the file? I’m not seeing where the GNSS configuration file allows for a COM setting of 0.

Kurt

Hi Tanner, no worries I see where the settings need to be changed. Thanks for posting this, it was of much help. I got mine working as well.

Regards,
Kurt

Tanner,

Thank you for sharing the solution! I’m glad to hear it’s working for Kurt as well. It will come in handy for other people who encounter this thread.