Connecting over USB doesnt work

My Reach RTK works well over wifi. Now I would like to get it working over USB, but it doesn’t. What happens:

  1. when I use just powered USB (from power source), then the module gets connected (I get green led)
  2. when I use USB from computer, then the module goes into blue-magenta blinking mode.

I tried with 2 different computers (win 10 and ubuntu 16.04). In Ubuntu, when I check dmesg log, it shows that the devices is connected and then disconnected. After about 10 seconds, its again connected, after 10 seconds disconnected. I also saw message “can’t set config #1, error -71” once. So it seems that it disconnects the device for some reason.

What should I do?

I needed to flash the firmware. For that I installed software for USB connection. With that, I am able to connect to the module using USB. I assume USB connection is not recommended for the module?

Anyway, I followed the link which worked:

It seems that your laptop USB port does not provide enough power for Reach to boot. It can also be due to a damaged USB cable.

Thanks for the reply!

Let’s say I get enough power - would it be “normal” to use rover from USB (rather than using wifi)? The current doc doesn’t say much about that (there is an old version in github, which has more information about connecting via USB). Is USB connection only for resetting/updating the firmware?

Reachview is accessible through web interface and your browser and wifi. That is the normal way.
You could ssh into reach but not use reachview, and I think @bide posted an indepth and highly alternative way to connect in a closed section.

I’m not sure what your intention is with this or if I understood your question?

I don’t want to use ReachView, just position output and IMU output.

Having multiple rovers using wifi includes a lot of configuration. If I could just connect my object to reach directly (via USB) then I don’t need to configure which object is connected to which reach module (IP). But as I understand, I should use wifi, USB is not the solution here.

Output solution via USB is covered in docs, about Imu i am not sure. Someone else might elaborate this.

This topic was automatically closed after 100 days. New replies are no longer allowed.