Connecting Navio2 to Mission Planner

Hello All,

I am new to the whole copter scene and I am building my own TriCopter using the Navio2. I am almost ready to fly except I am having issues connecting my Navio2 to Mission Planner. I want to connect my Navio2 to mission planner so I can flash the proper tricopter configuration onto my board.

I have follow the documentation down to where I enter: pi@navio: ~ $ sudo apt-get update && sudo apt-get install apm-navio2

Then I input: pi@navio: ~ $ sudo ArduCopter-quad -A udp: and the message “Raspberry Pi 2 with BCM2709!” pops up and just stays there for all eternity. I switch my setting to UDP on mission planner, set the rate to 14450, and then stare at the screen until the connection timeouts.

I have Mission Planner 1.3.39 installed and am using a Navio2 with a Raspberry Pi 3, Model B. I have two main questions:

  1. Do I need a telemetry transmitter and receiver kit in order for my computer to talk to my Navio2? Everyone else seems to have one in there setups and mine will be here within the next couple of days. Is there any way for me to just plug my navio2 into my computer, similar to the connection of a Pixhawk? It just seems odd that I would need a telemetry kit just for mission planner. If there was a step by step guide on how to do this I would be very appreciative.

  2. Could someone explain what the different inputs -A -B -C -D mean? Is this the form of serial connection between the laptop and the board? I was planning on plugging the telemetry receiver into the UART port on the board.

Thank you for your help, as I said in the beginning I am new to all of this and apologize in advance for how simple my questions may seem.

If you are building a tricopter, you should start ArduCopter-tri.
Also make sure you enter the IP of your GCS computer behind the -A option, when using udp.

You do not need a telemetry kit, a network connection is all you need for setup.
Navio2 is no MCU based flightcontroller, it is an IMU shield for the RPi. All connection capabilities are dictated by the RPi (except for the SBUS/PPM input and PWM outputs). Just as you can not connect PC to PC via a simple USB cable, you can not do this wwith the RPi too.

From the docs:
-A is for primary telemetry
-B is for external GPS
-C is for secondary telemetry (it can be used without primary telemetry)
-E is for secondary external GPS

I’m sorry I have been using ArduCopter-tri, I just copied and pasted it from the docs page.

I found out what my problem was, I hadn’t changed the baud rate on mission planner to be 14450. I have connected my Navio2 to mission planner, thanks for everyones help!

14550 is not the baudrate, it is the network port arducopter is sending the telemetry data on. You can choose any port you like, but stay away from any port below 1024. Those are the “well-known” ports, associated with certain network applications. The baudrate does only matter, if you use an actual serial port for telemetry/GPS connection.

Hello Brown,
I have exactly the same problems you had. I am trying to follow what you guys exchanged, but I cannot be able to connect my Navio2 and my Raspberry 3 model B. Can you please explain me in detail how you solve. I am using a quad. sudo ArduCopter-Quad -A udp:“IP”:14550. I also dont have a telemetry yet.
Thank you

1 Like

Hi sorry for the late reply.

I had my Pi connected vto my wifi and then I typed in sudo ArduCopter-tri udp -A:“IP”:14550 into the command prompt. Then I went to my mission planner and in the top right where it says connect, I switched my connection type to UDP and selected 14550 as the port.

After that it worked perfectly for me, I believe I wasn’t typing something in correctly originally.