Emlid

Community Forum

Connecting my navio2 board to mission planner


(Scott P) #1

I am using a raspberry pi 3 model B+ with a navio2 board attached to it. I have flashed the navio os with arducopter-3.5 running on it. I followed all the navio docs for the setup but I cannot get it to connect to mission planner. My pi is connected using an ethernet cable so I suspect the problem is me not having the right ip in /etc/default/arducopter but I have tried all of the ipv4 address in my ipconfig with no luck.

When I try to connect to mission planner it either gives me an error immediately or tries to connect forever.


This is a picture of my config file.

Any help is welcome. If you need any more information just let me know.


(Marc Lebret) #2

Hello,

192.168.137.1 may be your router IP, certainly not the IP of the computer running Mission planner.

Search in your computer network settings.

Marc


(Scott P) #5

Thanks. I’ll look around in there today. Could you give me an idea on where to look in windows 10?


(Tatiana Andreeva) #6

Hi @spogatetz,

You can find this information in the network properties.


(Scott P) #7

This is the same ip that comes up in the network settings for the ethernet connection.


(Tatiana Andreeva) #8

Hi @spogatetz,

May I ask you to post the screenshot?


(Scott P) #9


(Marc Lebret) #10

Hello,

From your Wifi connection settings, IP of computer (to be in the TELEM1 line) is 136.176.31.114.

Mine is 192.168.1.37

Marc


(Scott P) #11

Is this the IP I should be using even though my raspberry pi is not connected to the wifi? I am using an ethernet cable.

If it is then there might be another problem because I am fairly certain I tried this IP address with no luck.


(Sebastian) #12

Hi,

I understand, your PC and the RPi are connected with an ethernet cable? Is this correct?
According to your screenshot, the ethernet IP of your PC is 192.168.137.1. This looks like it is configured by hand. If you do not have the possibility to connect the RPi to the wifi, you will have to configure a static IP for it, too. If you have a smartphone, you might be able to enable a hotspot on it and connect your PC and your RPi to it. If you are using a PC of your organisation, make sure you are allowed to change its network settings.


(Scott P) #13

Yes right now it is connected via ethernet. To clarify, if I use a hotspot on my phone then I would not need to setup a static IP for my pi? In order to continue using an ethernet cable a static IP is required?

Thanks


(Sebastian) #14

If you are connecting PC > Ethernetcable > RPi, you will need to configure both ends with matching IP settings, because there is no DHCP server present. If you use a seperate router/smartphone hotspot etc., those devices will act as an DHCP server and assign IP adresses to the PC and RPi, so they can talk to each other.

DHCP > Dynamic Host Configuration Protocol


(Scott P) #15

Ok that makes sense thank you.