Connecting lidar tf02 to navio 2 UART

  1. Latest ardupilot version and correct setup from navio2 documentation as the udp to mission planner is working
  2. TF02 lidar will not connect via UART port to the mission planner software. Expecting data on the sonarrange and sonar voltage status values
  3. Step by step actions:

I get random inputs from TF02 using the screen command to the /dev/ttyAMA0 - UART connector.

Any help as to why not receiving data correctly would be much appreciated :slight_smile:

Hi @harryhancock,

Welcome to the community forum!

Could you please share the content of the launch file here? It might be helpful for me to take a look at the configuration parameters.

I will share my configuration:

TELEM1 is wifi UDP link is serial 0 at 115200
TELEM2 is serial 1 telemetry on USB0 -C /dev/ttyUSB0 is serial 1 at 57600
TELEM3 is Range finder (TF Mini) on UART

Capture d’écran 2021-03-17 à 17.01.15

-F /dev/ttyAMA0 is serial 5 of Navio2

I set serial 5 to 115200 and for range finder (9)

My range finder is a TF Mini serial, set to 20 in range finder settings. TF02 is 19.

Capture d’écran 2021-03-17 à 17.11.26

The display on the bench

1 Like

Thanks for your help!

I originally had the udp connection working but now it’s not connecting.

I’ve got the same config as you suggested and no firewall. Any suggestions?

Udp problem, No connection today… Maybe a W10 security update, I also had the problem today.

I disabled the firewall and rebooted PC and Navio after checking classic telemetry was fine. Udp is working now.

Hi Liudmila,

I have attached the launch file here:

Hi Marc,

I have the same settings as you in the serial 5 option and i changed the rangefinder 1 to be 19 for the tf02 in the full params list on mission planner.

As the uart connection is still not working and I’ve tried to see incoming data using the command below but getting gibberish

sudo screen /dev/ttyAMA0 115200

Let me know your thoughts


Same result with your command. Displayed data is not “clear”.

Hi @harryhancock,

Thanks for your patience.

As we don’t have the rangefinder at our disposal, we haven’t had a chance to test the setup ourselves. Let’s check whether it’s possible to troubleshoot this remotely.

At this point, as I understand, the data is being output from the rangefinder and received by Navio2. However, the data is not accepted by Mission Planner. It’d be helpful if you answered the following questions:

  • is it possible to connect TF02 to the other port?
  • have you tried setting the different baud rate?
  • have you tried tweaking some of the parameters and reloading Mission Planner to see if it helps?
  • have you tried checking the rangefinder with some other device? Does it work with is as expected?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.