Connect Mission Planner ; Select COMPORT


I have a question, just how to connect Mission Planner to Navio 2?

I am kind of just connect my laptop and RPI 3 with USB A male to A male cable, but there is no any comport.


When you connect rpi with navio to your home network, you use your local wifi and rpi IP address
It should be fairly good explained in the docs.
I assume you went through this step

And it should be available throught the connection menu in the top right corner of mission planner
The ipddress and port set in the navio setup is used here to connect mission planner


Hi thank you for your reply.

Can you check our steps first?

We put home wifi’s SSID and Passkey on the network section. Then, we change IP address (home wifi) on a big HELP screen not Finally we get A male to A male USB cable to connect them together. But, somehow, it doesn’t work. We assume because the cable is for Mac-Windows and Windows-Mac tranfers.

Are you able to run this command?
sudo nano /etc/default/arduxxxxxx

xxxx=copter, plane or whater the toy you use
Edit: and post a screenshot of it if you can.


I think I do not need to post a screenshot because it is just a blank screen if you type sudo nano.
So I am not able to run that command

Did you select vehicle and set autostart on?


On the “sudo emlidtool ardupilot” Screen, I chose version 3.5 because that is the only one which is available.

1 Like

What kind of A to A cable do you have? If it is simply a cable with two A plugs, it will not work.
If it is a USB Transfer cable, it should have some kind of hardware, perhaps in a box in the middle of the cable. Then it depends what happens if you connect the cable to your computer. There are serial transfer cables, which appear as an additional com port in device manager, or network transfer cables, which appear as an additional network adapter.
Either way you have to adjust arducopters telemetry settings to use the right hardware.

The command is:

sudo nano /etc/default/arducopter

sudo: run the following command with root rights

nano: texteditor

/etc/default/arducopter: the file to edit and the path to it


Thank you for your reply, but for me it is pretty hard to understand your reply. :open_mouth:
I thought I would need A male to A male USB cable because that USB ports are the only ports available on RPI, which means USB to USB is the only way to connect autopilot (Navio2) to computer.


Also, do we need to build the drone first before we code or do any computer work on navio os? Also, if Mission Planner keeps not working, can we just use MAVproxy? What do you recommend?

The Raspberry Pi is a tiny but full featured computer. As such it is a USB host. A USB connection can only be made between a USB-host and a USB-device. So it is not possible to connect two computers/USB-hosts with a simple USB cable. The cable needs additional hardware, that acts as a USB device for both connected hosts.

I would suggest you follow the instructions in the docs to connect MissionPlanner and Navio. If Wifi does not work, you could try a ethernet cable connection.

It is up to you, if you build the copter or do the software configuration first. You will have to do both after all.


Well but the problem is we can not connect Mission Planner, and now we are focusing on MAVProxy.

Mavproxy uses the same ways to connect to Arducopter/Navio as Missionplanner. Chances are if Missionplanner does not connect the way you try it, mavproxy will not either.


I am Andrews project partner, then how do you think we could connect Mission Planner? How did you connect it? Thanks

In general there are two ways to connect:

  1. Serial connection

  2. Network connection

A serial connection can be a connection via telemetry radios for example.

Network can be ethernet cable, wifi, or 3g/4g mobile connection etc.

Try to follow the docs, it is all very well explained there.


But we do not have telemetry radios, do you how to connect navio 2 with raspberry pi to ground station wireless without telemetry?

Most people use wifi.

1 Like

How can you connect wifi?

It is explanined in the docs here:

If you do not have a local wifi to connect the Raspberry pi to, you could use a smartphone to create a mobile hotspot, or do the same with a windows 10 computer.

1 Like

Alright thank you very much for your effort and time. I will figure it out it seems like it is my problem. I do not know what is local wifi though.