Configuration of Reach M + with Pixhawk 1, serial port 4/5

I saw that some people started a topic similar to this one, but were finished without a solution.
I followed the tutorial suggested by Emlid to connect the Reach M + to Pixhawk, however, I am not having success.
In fact I notice many people trying to follow the tutorial and not being successful.

The question is: How to know if the problem is in the connection of the cables that is not detailed in the tutorial or if the problem is in the configuration of the missionplanner. The base is easy to connect via TCP Client, but a Reach M + gps signal on MissionPlanner never worked.

I changed the communication protocol of the serial port 4/5 on the missionplanner “SERIAL4_PROTOCOL” to 5 “GPS” and 20 “NMEA OUTPUT” and neither option worked.

I created this pdf file with all the settings and connections between pixhawk 1 serial port 4/5 and Reach m + S1 port:

Reach_RS+_M+.pdf (949.8 KB)

I tried to configure the two protocols in Reach M +: ERB AND NMEA

I hope a solution comes out, because I don’t know what else to do.

Hi Grazziani,

Let’s cross-check the following settings just to be sure that everything is configured properly.

Position output of Reach rover:

  • Device - UART

  • Baud rate - 38400

  • Format - NMEA

Mission Planner settings:

  • GPS_TYPE2 - 5 - NMEA


  • SERIAL4_BAUD - 38



M2’s S1 to Pixhawk connection:

  • RX to TX

  • TX to RX

  • GND to GND

There is no need to use a 5V pin.

Yes, I used this configuration. Only Reach RS+ (base) connected with mission Planner, the Reach M+ not appeared how GSP2 on Mission Planner screen.

Hi Grazziani,

Sorry to keep you waiting.

We’re trying to reproduce the issue. I’ll get back to you with the news.

Hi Grazziani,

Sorry for the delay. We are working remotely, that is why it took us longer to reproduce the issue.

Please, try the following parameters in Mission Planner:

  • GPS_TYPE2=5 (GPS)

Please, use the following settings in the Position Output tab in ReachView:

  • Device - UART
  • Baud rate - 57600
  • Format - NMEA

These settings were tested on the latest Ardupilot firmware for Pixhawk, v.4.0.5. Please, reboot your Pixhawk board by detaching it from the USB port of your PC after the settings were updated.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.