complete noob to drones, navio2, and raspberry but trying to learn slowly. HELP NEEDED

I have no motors, esc’s, or drone frame but am slowly putting things together. I have a taranis x9d plus that I finally got to bind to a xsr receiver after randomly flashing firmware to transmitter and receiver about a month ago. It has sat on a shelf for a month while i took a brake and built a alt coin mining rig. I finally received a new raspberry pi in the mail after repeatedly failing to get a older one to boot up. Turned out that it was a bad sd card and both will boot up now. I fought through getting the raspberry to connect to computer with ssh over the past 2 days and now can get into the navio on the pi using putty.

Trying to follow this page https://docs.emlid.com/navio2/common/ardupilot/installation-and-running/ on connecting to ground station (mission planner). I am at this portion. (( Specifying launching options)) and figured out that I needed to use (( pi@navio: ~ $ sudo vi /etc/default/arducopter )) instead of (( pi@navio: ~ $ sudo nano /etc/default/arducopter )) to be able to change the ip address of (( TELEM1="-A udp:127.0.0.1:14550" )) to (( TELEM1="-A udp:https://www.whatismyip.com/ listing of my ipv4 ip address" )).

I saved it, then reloaded it. I then rebooted and ran systemctl status to verify ip address changed. which it did. However mission planner still does not connect.

Anyone know what I did wrong? Besides thinking I could do any of this that is.

Hi @chasthanhburns,

Welcome to the community forum!

You need to specify the IP address of the PC where Mission Planner is installed. It will look like this: TELEM1="-A udp:192.168.3.172:14550" where 192.168.3.172 is the address of your PC in the local network. You can check this guide that explains how to find out the IP address of the PC on Windows.