Compiling from source problem


I am trying to build APMrover from source (cross-compiling), but it is complaining about a missing “AP_Baro_VRBRAIN.h” and it is indeed not included in the libraries folder.

Hi Sebastian,
I’ve just tried to compile the navio branch from our emlid\ardupilot repo and it seems to compile okay.
Here are the steps:

export PATH=/opt/tools-rpi/arm-bcm2708/gcc-linaro-arm-linux-gnueabihf-raspbian-x64/bin:$PATH
git clone
cd ardupilot
git checkout navio
cd APMrover2
make configure
make navio -j5

Are your steps any different?

At the moment, only thing I notice is the -j5 option. I will check what I did again and see if I find what I did wrong.

It was the -j5 option. What is its purpose?
It was working before without it.

j option specifies the number of jobs to be run simultaneously, it allows to use several cores for compilation which speeds up the process. It should not affect the results of the APM compilation.

Sorry for taking up your time. I should not be messing around with those things when I’m tired.
I forgot to delete the already built APMrover2.elf, so without the -j5 option, the compile did not even start. With my tired eyes I thought I saw the same error message as before…
Now it is running with and without the -j5 option.
I still do not now why it was not working, but since it is working now, I am pleased.

No problem, I think that you’ve probably tried to compile with “sudo” the first time and after that without sudo it couldn’t overwrite the objects. It’s not really necessary to remove the elf file before compilation.