Compass problem

Just want to say that we hear you and are investigating. Sometimes things do not progress as fast as we would like them to. I will provide further updates when we have them.

Igor, thanks for the update. Please let us know if there is anything we can do to help, I would be more than willing to do more troubleshooting on my end.

Alright, I received my external compass module. Mounted with X forward, Y right, and Z down. Proceeded to try every thinkable combination of settings in mission planner to do the calibration. All of my attempts resulted in worse numbers, lol.

X: -323 Y:-374 Z:935

I also tried what Sebastian suggested, no effect.

Conclusions are that, unless I did something wrong with hooking up the hardware or the navio was ignoring it, this is not a hardware issue. I am sure hoping this gets fixed soon, I am close to wanting my money back…

A quick update. @george.staroselskiy did a great job this week to find the source of compass issues and make necessary fixes.

  1. External compass did not work for all Linux APM boards, so when you connected it Navio would still use internal compass. This is why the offsets are high even with external compass. This has been fixed.

  2. A driver for the second onboard compass has been written and it shows smaller offsets than AK8963. After calibration all three compases show almost identical values, so considering larger measurement range of AK8963 it might just be specifics of the sensor. High offsets are an issue because when measurement range is small, compass can be saturated with Earth magnetic field. This explains why with AK8963 you can fly normally even with offsets in red zone. Limits in APM are based on the HMC5983 performance.

All these changes went into APM master and we will provide a built version with fixed compass for you to test early next week.

Thank you all for your reports and patience.

2 Likes

@igor.vereninov, @george.staroselskiy, thanks for the update, looking forward to testing!

my ship 2 also has PI3 raspberry compensation of more than 800 I think for me to understand is demasido elebada.
Where informed of when the update list.
In raspberry PI3 and ship 2 update this with apt-get dist-upgrade.
Sorry for my bad English.
Greetings and thank you very much.

The new APM version is out!

There’s a couple of thing to bear in mind:

  • The new version is an unstable one, so be careful!
  • You can use up to three compasses now
  • LSM9DS1 has lower offsets. In order to use it, you need to enable it as an external compass in Mission Planner and set rotation to ROLL_180.

Some of you have wondered if high offsets are an issue.

It turns out it’s not. Mostly, because AK8963 has a way wider scale than HMC5883L’s one which the PreArm checks have been adjusted to.

@george.staroselskiy, that is awesome! I will be trying this out this weekend, fingers crossed, and thanks for the hard work!

Successful calibration and flight today! After installing the new release I calibrated and it recognized both compasses, results below.

Compass 1 has the same offsets, but compass 2 is within reason and I set that as my primary. After the rest of the calibration I did a test flight and stabilize worked great. Thanks for the fix guys!

On a separate note however, I am still having issues with althold mode. I have made a separate post for that, found here.

1 Like

Where to find this settings panel? On my APM Planner 2.0 (Mac) there is just a few options on the compass page.

@haxpanel This is Mission Planner. You can run it on Mac using virtual machine with Windows.

Smooth …
I’m a bit confused regarding the APM and MissionPlanner … I thought APM is the new version of MissionPlanner, so that it should know more than its predecessor.

Mission Planner is written by Michael Oborne using .NET technologies and thus works mostly on Windows.
APM Planner is a fork of QGroundControl made by Bill Bonney with interface redesign to make it look more like Mission Planner and give APM users a cross-platform GCS.
APM Planner lacks some of Mission Planners features and people tend to mostly use Mission Planner.

2 Likes

Thanks!

@haxpanel As someone who only works with Linux I ran into this issue too :slight_smile:

If you don’t want to go the VM route I think these setting will help. APM beta-testing

Many thanks for letting me know this! :thumbsup:

Missionplanner is a dot net application.
So if u have mono installed on your linux dist u should be able to download the zipped version of mission planner and then executing it like this: mono missionplanner.exe
It works for me and then I wont have to start my w7 wm :grinning:

Awesome, will give that a try. I really wanted APM Planner to work out but it still have a few rough edges.

Back to the compass issue … I am running a Navio+ and am using the latest image version (https://files.emlid.com/images/emlid-raspbian-20160408.img.xz) and also the APM.deb using the link in the DOCS.

I’ve only just rebuilt the system after relocating. It was previously on an older version and armed with no problems. Now it will not arm with the error relating to “Mag field”. I’ve seen solutions regarding the the Navio2 in this thread but not the Navio+.

What should I do to resolve this?

Thanks in advance.
Gary

9 posts were split to a new topic: Inconsistent compasses’ error on Navio 2 AC-rc1