Changing telemetry baud rate?

Hi all,

In the Navio+ docs, I read this.

“When using UART for telemetry please note that default baud rates are: 115200 for primary (-A) 57600 for secondary (-C) 3DR Radios are configured for 57600 by default”

How would one go about changing the default baud rates? For instance, how would one set the primary telemetry port to 57600 instead of 115200?

Thank you in advance!!


Hi Walter,

You can do this within APM Planner or Mission Planner by altering the Serial0 (-A) and Serial1 (-C) baudrate parameters.

Thanks for the reply!

Okay, so does anything need to be modified on the Navio side of the system for things to work correctly?
I assumed that the baud rate would have to be altered both on the pc and the Navio. I am probably overlooking something obvious.



Baudrate on Navio is controlled by parameters in APM. If you are trying to connect to your PC, than you need to set the correct baudrate on PC side as well.

Baudrate has to be set on both ends identically for UART to work.

Oh okay, that is what I figured. So on the PC side, the baud rate is changed through mission planner, but how does one alter the parameter in apm?



You need to connect to mission planner first and than you can change parameters (SERIAL1_BAUD/SERIAL0_BAUD) of APM that control baud rate in it.

@Walter_King , Hello, did you sort this out? I would just like to add, you can look up your baud rate in windows buy going to the devise manager, finding the usb that correlates with your telemetry radio and opening up the properties. Its in one of the tabs. Then just match up the correct com channel with the baud rate and you should be able to connect no problem. That is if you are using a telemetry radio, if using udp its a bit different.

You usually only have to select the correct baudrate in your GCS application. No need to dig into windows system settings.

@schuermannsebastian , Where did I say he needed to change anything in windows? I was suggesting a resource if he was having issues connecting in mission planner to sort out the correct match up of baud rate to com port. Sorry if that was not clear.

@aquila Thanks! I’ll keep that in mind if I continue having problems.

@igor.vereninov So if I understand correctly, you connect to the GCS app using the default baud rate and then when the baud rate is changed on the GCS the baud rate on Navio is adjusted accordingly as well? Thank you for your patience. Much appreciated.


You should be more specific about your setup. You never mentioned what telemetry hardware you are going to use.
For 3dr radios on default settings, start APM with option “-C /dev/ttyUSB0” for 3dr radio connected to USB or “-C /dev/ttyAMA0” for UART.
In Missionplanner select the com port assigned to the 3dr radio connected to your computer and 57600 baud. Click connect.
After the connection is established, click on the “config/tuning” tab and then on “full parameter list”.
Click away the warning and scroll down till you get to SERIAL0_BAUD. There you can change baudrate for option -A.
A little bit further down the list is SERIAL1_BAUD. There you change baudrate for option -C.
If you change anything, you have to click “write params” to send the new values to APM. Then restart APM and select the new baudrate in Missionplanner for the next connection.
Changing baudrates only applies to serial connections, udp or tcp connections over wifi or ethernet cable are not affected.

1 Like

Okay, that makes perfect sense. Thanks!
I am planning to use either dj rf900 radios or xbee radios.


I am using XBee Radios. Xbee PRO S1’s to be exact. I have used XCTU to change the baud rate in the xbees to 57600, and I have checked the command I am using to start my APM and it is this:

sudo ArduCopter-quad -C /dev/ttyAMA0

For one, when I start the APM using that, I get a bunch of weird characters on the screen. and it randomly will say things, but its mostly odd characters.

I soldered the wires up as this:

Navio+ side / Xbee Side:

black / GND
red / +5V
white (TX) / Dout (RX)
green (RX) / Din (TX)

I have no idea why this is not working and any help would be sincerely appreciated!


Also I forgot to add, this is the wire harness that came with the Navio+ that plugs into the UART port. Most of you probably already knew that though!

On my set up I have the blue uart line running to tx on my xbee. Unless you have a different cable than me, blue should be the uart rx pin. A uart pinout can be found about half way down this page.
Hope this helps!


The text on the screen is the telemetry stream. If APM is not able to find/use the telemetry port you specified, it sends all telemetry to stdout, which is the console.
Your APM start command looks ok.
I am at my smartphone right now, I will get back to you as soon as I am at my PC.

Whenever I initialize apm using option -A I do not get the text on the screen. However, if I initialize with option -C I get the text even when my telemetry is functioning properly. I didn’t think much of it, but is this normal?


I used this link here:

for what I thought was the pin out. Since the Navio+ didn’t have it, I assumed it was same with the regular Navio board. There was nothing in the documentation that stated otherwise. It’s a bit frustrating when that happens. :frowning:

Thanks for the heads up Walter. I hope this resolves the issue. One thing as well, I used another USB based socket for my Xbee and plugged it into a usb port on the raspberry pie and tried using the “-C /dev/ttyUSB0” command, but it still did not work. :frowning:

I still get the stream of silly characters and no connection between Mission Planner and my quad.

It appears the pinout in the navio docs is correct, but the wire colors in the diagram are different than what they are in reality. I would agree; that is quite confusing.

I have not yet tried the /dev/ttyUSB0 command yet so I can’t be of much help there.I don’t have two USB adapters yet. Let us know if you get it working though!

I get the characters in the command line regardless of whether my telemetry is working correctly so I don’t think it necessarily indicates a problem. However, I am curious as to why they are present, especially as they do not appear when using option -A


The wire colors in the diagram are the same as the wire colors that I have on my cable, that came from Navio. So I am still confused as to why this is not working. :frowning: Especially if I have it soldered on correctly.

How do configure if I use 3DR radio on USB port? and external gps on UART?