Changing PID values in extended tuning in Mission Planner

Hello, i run into a small prob that is driving me crazy lately.

I run the autotune on my new Quad, after that i really didn’t like the way the quad flew so i decided to redo the conf manually.

Having a bit of experience on PID tuning i started…

But…it looks like Mission Planner won’t allow me to tune each parameter, they all seem to be locked, if for exapmple one value is set at 0,5 i can only lower it but not make it any higher (unless i force it in the full parameter list). It loomks like the actual pid values are the top values the software will let me use.

Another question, does anybody know wich of the parameters is the old FF (feed forward)? Basicly the % of command that goes direct to the quad without the loop filtering it?



I suggest not to use auto-tune. In my opinion this function is poorly implemented by the ArduPilot developers.
I think it can’t work even theoretically and the chance that the results will somehow work is as high as the chance that the copter will behave either too sluggish or too responsive. This is because of the fact, that auto-tune modifies two PIDs at once, not caring about the fact that the user input has to be considered as well. As the desired attitude is the difference between the user input and the current attitude. Unfortunately, it just checks overshoot and stabilization, not the response towards user input.
After getting miserable PIDs you need to change the values in the All Parameter Tab. I also had this kind of problem.