Cant't arm/takeoff due to bad compass health

I have my managed to connect my navio2 board to mission planner via telemetry radios. Right now I just want to see if I can get the rotors turning so I am not super concerned about navigation or safety checks. All of the prearm checks have been disabled. Even with these checks disabled if I do Ctrl-F and click arm and takeoff it says it failed to arm due to bad compass health. How do I fix this?

Also, when I try to calibrate the compass via onboard calibration, I click start and nothing happens, even if I rotate the drone.


If you are just in the try and check process, it is better to use the Raspberry built in Wifi to do it.

You can bypass the arming checks. Do not forget to re-enable them before flying.

You do not need to use your main battery and power the motors to check Arming and monitor RC-Out. You can do that by powering the Raspberry with external source. Use your RC transmitter to Arm, move the power lever to middle and check the RC-Out. When happy with it you can move to the next step and power the main distribution board.

Use the Wifi link to calibrate compass and other components.


1 Like

For some reason I am unable to get a connection over wifi.

Hi @spogatetz,

I’d recommend you using an external compass with Navio2.

1 Like

The compass will not be used for our purposes. Is it possible to fly without an external compass?


Yes, you can disable compass in the pre-arm safety check.

I disabled all pre arm checking but I still cannot arm.


Could you try to calibrate the compass outside?
Do you use the latest Navio2 raspbian image?


I managed to arm the drone in a different environment. Now when I try to takeoff it says “flight mode change failed”

Edit: I think it is because my GPS has not found a position (“GPS: no fix”). How do I initially setup the GPS?

Hi @spogatetz,

Could you post your hardware setup photos?
Did you test the drone outdoors?
Which flight mode did you try to take off?

I was trying to takeoff in stabilize mode but I think it was trying to switch to auto which is why it failed.

I will try to test it outdoors.

Hi @spogatetz,

GNSS antenna requires a clear sky view to detect satellites.
I’d also recommend you to place the antenna on a ground plane.

Keep us updated.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.