Can't import DXF

I am trying to input a DXF to reachview3 to test the new function, but it doesn’t work.

I have a CVS that I download from a survey in wgs84 utm 19s, I put it in Civil3D, then I export the points in three different versions, 2010, 2013 and 2018 but every file gives me error importing.
What are the characteristics that the points file should have?

I leave files in compress folder, not I don’t know what is the issue.

WGS_UTM_19S-DXF_& (194.2 KB)

Can you help me? Please :grin:

We have issues sometimes with our other GNSS and robot controllers importing .dxf or .dwg. Usually what I do is save the .dwg as another work file and purge all unused layers, blocks and defpoints. I also turn on all layers and zoom extents to make sure there’s not any wayward entities that might be inadvertently on the other side of the planet. If it’s linework to export to the controller, I also put all entities on one layer. 9 times out of 10 this works and we have no issues. When it doesn’t work, there’s usually something wrong with the .dwg or .dxf file. I also save the .dxf as a r2000 file and this also works.


Hi Bernardo,

Thanks for sharing your files! I’ve tried to import them to ReachView 3, and it didn’t work for me either.

When I opened these DXF files in the QGIS app, I noticed that they contained blocks. However, at the moment, ReachView 3 supports the import of points only. So I think that changing the type of objects in the DXF files will help you.


First thing we do with every project is completely tear down any CAD files we get through a cleanup routine. This gets rid of XREF’s, duplicate linework, explodes blocks and purges any remaining unused data. We end up with individual files for property/control, each utility scope, grading and site layout. When we get revisions we pull the affected scope out of the new CAD, archive our old file and all our master file XREF’s stay intact. You also need to watch out for AECC objects. They need to be exploded or deleted before saving as a DXF.


Hi Julia,

Yes, I tried doing the same, exploited the DXF, I also loaded the points in Qgis and exported them as DXF. The last option I used was to open the DFX in Global Mapper to check that they were points and then I exported them again in DXF, but it did not work. I tested 3 different options.

1 Like

Hi Bernardo,

Hmm, it sounds like something that requires investigation. Could you share these DXF files with me?

In the meantime, you can also try to convert your CSV to DXF using online converters such as MyGeodata Converter and try to upload it to ReachView 3.

Here is also a Demo project in DXF format. It should be easily imported into ReachView 3. The coordinate system of the project is CH1903+/LV95. So you can check if it works for you as well.

1 Like

Hi @julia.shestakova

Can you share the “Demo project in DXF format” again? The link has expired.

Thanks Roland

Hi Roland,

Here it is.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.