Can't get reach to fix

Seems to be lots of problems getting reach units to fix. I had mine to float a couple of day ago today could only get single not even float?

I notice that I put the elevation in the base at 541.5 meters. The rover is finding elevation at 515.0 plus or minus several meters. I know the elevation of the base is 541 to 542 meters. So I tried the rover in single mode and it still was finding around the 515 meters.

Also the base does not seem to hold the hz rate as I tried setting at other than the 10hz gps cmd and it would seem to lways revert back?

I think the documentation is very poor!!!


For elevation I know GPS uses ellipsoidal height, sounds like your entering orthometric height (i.e. topographic map height).

You need to find the geoid height of your exact location to subtract from your orthometric height to get the ellipsoidal height.

That sems to be the problem alright. But I see several different geoid calculations, how do I know which to use? I am in Canada if that makes a difference


Just put in your exact Lat. and Long. (use link above) in the correct format where it says:
Enter Latitude:
Enter Longitude:
Then click Geoid12A Computation.
It will give the height.

For example a random point in Canada:
50.085732 Lat.
95.781594 W Long.
Geoid height: -29.487 meters

288.341m (Orthometric/Topo) - 29.487m (Geoid) = 258.854m (Ellipsoidal height for the GPS)

Google Earth is a good way to get fairly accurate coordinates and elevation.

Yes tried that did not work. It is closer though. Tried adjusting to what the rover was reading just keeps staying away.

I meant that their are several different geoid calculaters egm2008 egm96 egm84 geoid 12A.


Geoid12A and Geoid12B are both the most accurate ones currently. What helped me is to cut out a perfectly smooth, flat, and round 100 mm in diameter circle from an aluminum cookie sheet. I then glued that to a flat plastic lid as a level ground plane for my antenna. I drilled a hole next to the antenna for the cable to exit the bottom very close to the antenna. Also moving away from houses, power lines, tree etc. of course helped. I’m not sure what else could cause your problems.

at me the solution was in advanced settings:


Changed : fix and hold
Lock,count from 0 to 200
Ar from 3 to 2

pos2-armode =fix-and-hold # (0:off,1:continuous,2:instantaneous,3:fix-and-hold) ## GPS integer ambiguity resolution mode
pos2-gloarmode =on # (0:off,1:on,2:autocal) ## GLONASS integer ambiguity resolution mode
pos2-arthres =2 ## Integer ambiguity validation threshold
pos2-arlockcnt =200 ## Minimum lock count to fix integer ambiguity


Just wanted to note:
pos2-arthres is actually the threshold for RTKLIB to start considering solution fixed. By lowering this parameter’s value, you just allow RTKLIB to call a worse solution fixed.

ok. you mean 3 is for a better rtk…!

Yes, exactly. Also, float solution in general gives really nice accuracy, so waiting for fix is not always necessary. You should check for yourself by connecting RTKPLOT and watching the coordinate fluctuations.

ok thank you! i will try this! when i use rtkplot i see what reach gives me for output…

i wanted to buy a gps receiver and use it…
now i learn many about gps… and now about post processing. - fine!!

in rtk post i insert rinex obs for base and rover.
do i need to use the 3. inputfile rinex*nac/clk,sp3…?

These are optional, you can skip them for now.