Can't connet RS2 to tablet

Hi all. I feel like a fool because this is likely a simple thing but I can’t figure it out: I can’t get Emlid Flow to recognize either of my RS2 units. I am trying to connect for the first time. Once the wifi light it solid white, I connect to that network but, when I go into Flow, it says, “No receiver connected.” I have tried on a Samsung Galaxt Tab S6 Lite and also on a Google Pixel 3A. I have tried with one RS2 and the other off, have tried the reverse (the one that was powered on is now off and vice versa), and I have tried with both on. No luck. Is it just me? Thanks in advance.

Try your browser

Hi Matt,

I saw your email at Let me quickly double my answer here.

What is the LED status of the unit’s when you’re connecting to them? You can share a short video with me so that I can clearly see them.

Regarding the app, please make sure you’re working with the latest Emlid Flow 8.8 version. This will make sure you’re working with the latest updates. Do you have an iOS-based device at home to try connecting just in case?

Also, please check out if you can open the Reach Panel of the unit as David suggested. For that, please do the following:

  1. Connect your phone to the unit’s Wi-Fi
  2. ​Open any Internet browser on your phone
  3. Type to the address bar and go there
  4. If you see no connection, please try

Please share the screenshots of these connections. They will tell us if it’s possible to connect to the unit at all.

1 Like


Whit android existe diferente OS and each one with different tricks.

Some will ask you to activate the location, others need to deactivate the mobile data, in other occasions I have seen that it is necessary to wait for the system to ask “if you want to stay connected to the network even if you don’t have data”. Try those little things, I’ve been through something like this with many different phones(& tablet) and those details can make you connect successfully.

Hello Polina (and everyone else trying to help and/or following along),

Thank you for your assistance.

-When attempting to connect to my units, the white wifi indicator is lit and the other 5 lights light up white in rapid sequence. I can’t figure out how to upload my video to this message but I can send it in a reply to your email.

-I am running Flow 8.8 on both my tablet and phone. I am currently in the field in Guatemala and, unfortunately, don’t have access to an iOS-based device.

-I am unable to access the Reach Panel. After connecting to the unit’s wifi attempting to access the Panel, I get the message, “This site can’t be reached.” (screenshot attached)


Thanks, Bernard. I think I have tried every possible combination! So far, nothing has worked.

and do the lights continue in a loop or at some point stay on and steady without flickering?

They just keep going in a loop until I eventually give up and shut everything down.

Hi Matt,

I’ve received your video, thank you! Indeed, you can’t connect to the unit because it gets stuck in loading. The boot-up process is not finished so you can’t access it in the app.

Do I get it right that this happens with both of your units? Is it the first time you’re setting them up?

While we’re looking into the report of why the flashing process fails on your PC, can you also share the invoices on these units with me? You can do it either via private messages on the forum or via email.

1 Like

Hi Polina,

Thanks for your reply. I’ve sent the invoice via email. And I’m glad to have an initial diagnosis.

Yes, both units do the same thing. When I first got the units, I set them up with my old table but did nothing after that since I was not doing fieldwork. I bought a new tablet to use with them and that’s where things stand now.


1 Like


I’ve received your invoice, thank you!

We’ve checked the issue report from the failed flashing session. It looks now like there are some issues on the USB port that the software can’t recognize the receiver.

We believe that reflashing the devices will help to restore them. So here’s what I suggest checking with the Flash Tool:

  • try different USB ports of your PC, use different cables
  • try switching between USB 2.0 and 3.0 ports
  • disconnect all other devices connected to the USB ports of your PC while flashing Reach
  • if possible, check the Flash tool on another PC

Please let me know if this works for you. If not, please attach the new Reach Flash Tool logs for us.

1 Like

SUCCESS!!! While my shiny, new, powerful laptop kept failing to update my receivers when using the Reach firmware flash tool (despite trying every available port and cord), my colleague’s ancient laptop was able to successfully update both of my receivers. My tablet now recognizes and connects with both. Thank you for your help, Polina!


Hi Matt,

Thanks for sharing the results! Great to know you’re working just fine :slight_smile:

In case of any further questions, we’re ready to help you here on the forum or via