Can't connect via ReadyToSky telemetry on OSX Mojave 10.14.6

Hello,
I have an issue connecting with the readytosky 915mhz telemetry set that is recommended for the navio2 and rpi3b+ and QGroundControl as well as APM Planner. I currently have one of the devices plugged into the UART port on the Navio2 and the other in the USB port of my MBP.

If I view About This Mac->System Report->USB, I can see the device connected. So I don’t believe that is an issue.

I have solid green lights on both telemetry devices, and have no issue connecting over wifi with the TELEM1 var set to my IP like so:
TELEM1 ="-A udp:192.168.1.4:14550"

However, when I try to connect via the Telemetry device, nothing ever happens.

Any help would be greatly appreciated.


Hi Joshua,

Could you share the screenshot of the Device manager while the radio is connected to the PC? How is it defined?

Hi @tatiana.andreeva sure. no problem.

Is this what you are asking for?

Hi Joshua,

Sorry if I wasn’t clear enough, I meant the Device Manager on Windows. I’d like to check how your PC defines the connected radio.

Also, please, run the following command on RPi and post the output here:
dmesg | grep -i tty

Hi @tatiana.andreeva No problem. I understand now :slight_smile:

Here is the image that is showing how my device manager defines the connected radio on my macbook pro (which is my host or ground control station)

And here is the output of the command you mentioned:

$ dmesg | grep -i tty
[0.000000] Kernel command line: 8250.nr_uarts=1 bcm2708_fb.fbwidth=720 bcm2708_fb.fbheight=480 bcm2708_fb.fbswap=1 vc_mem.mem_base=0x3e200000 vc_mem.mem_size=0x3f600000  dwc_otg.lpm_enable=0 console=ttyAMA0,115200 console=tty1 root=/dev/mmcblk0p2 rootfstype=ext4 elevator=deadline fsck.repair=yes rootwait quiet splash plymouth.ignore-serial-consoles
[0.000294] console [tty1] enabled
[1.030457] 3f201000.serial: ttyAMA0 at MMIO 0x3f201000 (irq = 87, base_baud = 0) is a PL011 rev2
[1.030491] console [ttyAMA0] enabled

Please let me know if you need anything else!

Thank you~

Hi @tatiana.andreeva just wanted to follow up on this! Hope you are well!

If I’m right, your Telemetry radio is plugged to the UART to USB converter.

Your Planner is looking at a bluetooth port, not the USB it should…

Hi @mlebret thank you for your response! If you take a look here in my response, you can see that those are my exact settings. Am I missing something?

It is a copy from your screen, with bluetooth connection???

You need to select tty USB serial

41

in order to connect the telemetry radio

@mlebret yes, that is correct.

As you can see (image below), I don’t have that option. Everything is only Bluetooth.

I have the telemetry plugged into the UART port on the navio2 and the other telemetry module into the USB port on my macbook pro. Both lights are solid green and there is no option for usbserial.

The driver is missing.

Go https://www.silabs.com/products/development-tools/software/usb-to-uart-bridge-vcp-drivers

and download and install for OSX.

@mlebret i don’t think that’s it for 2 reasons. I have already installed the driver, and secondly my Macbook pro can read it. Please see the image I posted previously: