Can't connect to the network

Hey, I have some issues with connecting to the network knowing that i have reconfigured wpa_supplicant.conf and i’m using Raspbian for Navio OS, when i do ping command i get unknown host
Any Help would be appreciated


Verify the presence of quotes around SSID and Password:


Sometimes you have to push a button on your modem to accept new client?


1 Like

Thanks for the reply, well there is no button in the access point and i’m pretty much sure that i added the quotes.
Any other suggestions!! you can see what i did in the following photos:

after rebooting
still no connection

There is a typo in your wpa_supplicant.conf

You use underscore in WPA_PSK, it is WPA-PSK

Here is my ifconfig result:

pi@navio:~ $ sudo ifconfig
eth0 Link encap:Ethernet HWaddr b8:27:eb:52:1a:e7
inet6 addr: fe80::ec9d:1183:dac9:5a05/64 Scope:Link
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

intwifi0 Link encap:Ethernet HWaddr b8:27:eb:07:4f:b2
inet addr: Bcast: Mask:
inet6 addr: fe80::eb16:fcc6:6dad:4bf1/64 Scope:Link
RX packets:191 errors:0 dropped:61 overruns:0 frame:0
TX packets:183 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:23287 (22.7 KiB) TX bytes:23076 (22.5 KiB)

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:191 errors:0 dropped:0 overruns:0 frame:0
TX packets:191 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1
RX bytes:15606 (15.2 KiB) TX bytes:15606 (15.2 KiB)

Hope you solve your problem,

W10 remark: I have to use PX4 console (from PX4 Toolchain) to connect via ssh to my Navio.


Thanks i will try it. i had something confusing i wish you tell me your opinion about it, Well some friend shared his wifi and i tried to connect to it with my RPi and it worked unlike the wifi i showed in the configuration file, Any ideas about what happend?? knowing that didn’t add the line of WPA-PSK in the file and i can connect to that wifi using my laptop so i’m pretty much sure that i did no error of writing
Thanks in advance

Hey i corrected the error and reboot again but still no connection

Any other suggestions!!! Knowing that i can connect to the same wifi with my laptop

Hello there! We’ll need a little more information to get to the bottom of this issue and more specifically:

  1. What Raspberry Pi is in use?
  2. What Wi-Fi dongle are you using?
  3. Could you also share with results of sudo iw wlan0 scan | grep -B7 -A50 IBISC? The latter scans for available networks and filters results to show information relevant to your one.
  4. Is it possible that your network s 5Ghz whereas your dongle only supports 2.4Ghz?

I also recommend using this tip to populate the wpa_supplicant.conf.

Hey here it is what you asked for:
I’m using RPi 3 model B

Since i’m working with RPi 3 i don’t need wifi dongle
and here you can find the rersult of sudo iw wlan0 scan | grep -B7 -A50 IBISC

and there is another thing, i messed my /etc/network/interfaces up while trying to solve the problem maybe this could be problem. here it is the file after the changes:

please Any suggestions!!??

Seems like you don’t use the latest stable. I guess once that one is flashed, your problems will vanish.

Hey again, well i tried the new release and now i’m having an extra problems :disappointed:

  1. the scaning is not supported :

  1. Even the result of sudo iw wlan0 scan | grep -B7 -A50 IBISC is not available:

  1. Could you please tell me what to do next after populating the file command:

here you can find the file after reconfigurations:

Please any other ideas!!!

We renamed the internal Wi-Fi to intwifi0 (I.e. you’ll need to run iw intwifi0 scan. That’s why your command doesn’t work. Could you try using an external dongle and see if it works out for you?
I don’t understand why did you run wpa_passphrase the way you did. It should be sudo bash -c "wpa_passphrase IBISC-ST-INV 1234456789A >> /boot/wpa_supplicant.conf".
Could you also post the output of ls -l /etc/wpa_supplicant/wpa_supplicant.conf and dmesg?
You can also try removing the first line with the country code and see if it helps.

well, the scanning show the wifi i’m using
and for the dongle, I dont have one but before installing the new release the one i used before have no problem connection with other wifi but it couldn’t connect to this wifi (IBISC-ST-INV) Knowing that it has no filtering and can connect to it with my LapTop
the command >ls -l /etc/wpa_supplicant/wpa_supplicant.conf outpus is:

and for dmesg :

well it is so long sorry for the camera resolution if it is not clear enough just tell me
and for the country code i removed it and rebooted but still not working.

Hey,I haven’t managed to get any WiFi connecting yet,when scanning it shows the wifi that i want to connect to But I cannot connect to it. When I used the ethernet cable it is worked. but i couldn’t ssh to the device.

and this is form my Laptop

is it a must to be connected to the same network to ssh???
suggestions are welcomed

Hey, The problem is solved. from what i read There is something called dhcpcd (daemon) service. This seems to be run before the system parses the /etc/network/interfaces file.
so to overcome that the daemon dhcpcd should be disabled using this command sudo update-rc.d -f dhcpcd remove or another option is to force the daemon dhcpcd to retrieve the IP address you like by reconfiguring nano /etc/dhcpcd.conf file. That’s what i did actually.
I wonder how come that no one had this problem before. Anyway thanks for the suggestions you gave guys.

1 Like