Can't connect to Reach RS via Reachview

Hi there

I recently changed phone (Oneplus 3 to 6) and now I can’t connect to Reach RS via Reachview. I created a hotspot on my phone like I have always done but Reachview won’t find my Reach RS. The problem only persists on my new OP6. All my other older devices (phones and tablets) work like they have always done.
I’m 100% sure that the name and password are correct cause I’ve checked them multiple times. Any advice how to address this problem?

EDIT: The Reach RS connects to my hotspot but it wont show up in Reachview no matter what I do

in hotspot settings you see IP adress reach antena (section conect device). this adress write on internet browser.

I know on my Note 8 (Verizon) and setting up a hotspot, in my case, I had to go to the settings CONFIGURE MOBILE HOTSPOT, SHOW ADVANCED OPTIONS, then UNCHECK “Use 5 GHz band when available”, then SAVE.

Maybe try that to see if that works. If not, it’s something else…obviously it’s a setting on your new device since it worked before and on other devices. So the culprit is something on your new device and not necessarily a Emlid problem perhaps.

Already tried that. 2.4 and 5Ghz bands both gave same results. It seems that the problem is related to OP6. I’ll have to dig a little deeper to my phones settings after work.

What Ip address is handed out by your Hotspot?
Address in the range of 192.168.2.X might cause issues.

Ip address is if I remember it correctly but I’m sure it ain’t 192.168.2.x. This is kinda strange since my really old 3rd gen ipod touch can connect to the hotspot created by OP6 and it works like a charm

do you have the latest version of ReachView? If so and still no go…what about installing the DEV option (with a phone etc that works connects obviously) if you think you want to. You can always reflash back?

Yes I have the latest version. I’ve already installed Reachview dev2.13.1 but I did nothing to solve the problem. OP6 connects fine to Reach RS when I connect RS and OP6 to my home Wi-Fi. There must be something strange in the way the phone creates the hotspot but can’t figure it out

is the hotspot name complex? maybe try a simple name?

google search: oneplus 6 hotspot problem

maybe some help there.

Google was my first place to look but couldnt find any answers there. The hotspot works on all the other devices I own but the Reach can’t find my RS when it’s connected to hotspot created by my phone. It even shows as connected device on OP6 but no connection via Reachview

Hi Jaakko,

It is more likely the mobile phone issue. So if you want to use your phone with Reach the only workaround is to get access to ReachView via a web browser using Reach IP. You can determine Reach IP using any network scanning tool.

1 Like

I think the problem is in Reachview app. It can’t find the Reach RS. When I create the hotspot on my phone and try to connect via reachview app it doesnt work, but when I use chrome on my phone and connect using IP-address the connection works

Well in that case, you’re still able to connect using a browser which most do anyways. I don’t really use the “app” as it is iffy sometimes…but via browser seems much more consistent connection.

I figured you just couldn’t connect at all no matter which route. So it sounded like something wrong with the unit itself or your new phone…but you can obviously connect via browser which is just fine.


By saying that it’s a smartphone issue, I’ve meant that some phone models run hotspot in a non-standard way. We will try to fix it in future, however, in the meantime, please use a web browser to work with your Reach.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.