Cant connect to Reach RS+ after firmware update!

I am having insane amounts of troubles connecting to my Reach RS+
I ran the firmware upgrade 2.16 since it was showing 2.14. After the update, I tried to connect to the Reach RS+ using my ipad that worked perfectly before the update. Now the ReachView app shows ‘Welcome to ReachView’ and wont connect to my network (tried 2.4g, 5g, mobile hotspot on 4g) NOTHING! Tried on 2 different ipads (ios 12 and ios 11), 2 different android phones. Nothing. Keeps showing the red box ‘Reach is connecting to another network’ Great! it never connects. Blue light doenst blink. Feeling pretty frustrated right now.

Can’t you guys just let us skip the update process since I have already done this via the usb cable and your firmware updater. I mean if you look at the forums, there are lots of people complaining about the same thing. Just skip the fancy, non-functional app and let us get to work.

  1. Firmware image and ReachView version.
    2.16 from this page
    https://docs.emlid.com/reachrs/common/reachview/firmware-reflashing/#windows
    ReachView version 1.4

  2. Detailed problem description. How does observed behavior differ from the expected one?
    Observed. It doesnt work. Expect. It should just work. Not sure why the app has to do an update after a manual firmware update. Kind of pointless.

  3. Your step by step actions.
    See above.

The upgrade finally worked after 3 hours of fighting, multiple firmware reinstalls, multiple changes to my wifi network and some voodoo magic.

Developers, please give us an option to bypass the forced update check after a firmware upgrade. If we choose to do a manual firmware upgrade, then we should not be forced into being stuck with a non-functioning unit. This was a serious exercise in frustration.

If you really want to bypass the requirement to perform an update after just flashing the firmare, you can.

I don’t recommend it, but if you are offline or somehow stuck, then you can issue this command after sshing into your Reach:

touch /data/system/etc/reachview/first_time_setup.cfg

After that, just reboot it:
reboot

Thanks for the tip but I couldn’t find how to SSH to the Reach in the user manual.

Also, why is it not recommended to do an update after flashing the firmware? Maybe I misunderstand but isn’t the latest firmware, the latest update?

Thanks for taking the time to respond.

Cheers!

PM sent

THanks!

Hi @norris

This step needed not only for checking for updates but to check to Reach hardware/software, Wi-Fi connection, Reciever updates and make Time sync.

Glad to hear that now your device is OK.

I’d recommend you to watch our first update video tutorial here in case you’ll face this issue again. It should help you with it.
Also, feel free to ask your questions on the forum.

HI Andrew,

Thanks for the link. I watched it when I was trying to setup my Reach+ and it was not useful in troubleshooting my issues since it does not suggest what troubleshooting steps a person should take. My suggestions would be to make some additional videos on troubleshooting connection problems and also how to SSH to the device if it is not responding.

As I understand it is not possible/not recommended to bypass the force update, I think that having some ‘help’ videos showing some common troubleshooting would be very beneficial.

We’re here to help you with troubleshooting :slightly_smiling_face:
However, I agree that some kind of video tutorial/guide can be useful.
Thanks for your suggestions!

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.