"Can't connect to Reach" message


Reach RS2 right out of the box, connect android device to it’s Wifi fine, open ReachView3 and see the reach and IP, however the android device fails to connect with “Can’t connect to Reach” message displaying. Not sure what to do now!

Any help appreciated.




It is most likely because you are running the stable version of Reachview 2 on the device. ReachView 3 only works with the Dev Update.

Try connecting using ReachView 2 and get it connected to a WiFi network. Then you will be able to download the Dev Update.

1 Like

Hi, managed to get the Dev update on and updated firmware. Set WiFi to the hotspot I want to use onsite and turned on Bluetooth to the android device I want to use. Now onsite and the android device won’t connect to the RS2.

Is the problem that the device is also providing the WiFi hotspot?


You can use the ReachView app only by accessing the receiver in the same network. Bluetooth connection is used for position output and correction input/output only.

So if the Reach RS2 is broadcasting the hotspot, you need to connect your Android device to its hotspot. Then you will see the receiver in the App.

Also, make sure to disable the mobile data on your Android while connecting to the Reach’s hotspot. This will ensure that the device is accessible for you.

Hi, the reach isn’t providing hotspot, the android device is. But therefore the android device is using the network SIM rather than the hotspot it is creating. So I guess that is the issue?


You cannot view the Emlid on the same device you are using as the hotspot. You need a second device.

Use your first Android to provide the hotspot you want and connect the Emlid to its network. Then take another device (not the Android broadcasting the hotspot) and connect it to the same network (similar to how you downloaded the Dev update).

You will now be able to see the Emlid unit on the second device.

I think this is an incorrect statement. (At least I’ve done it before)

If the led of the RS2 is blue, it means it is in wifi-client mode (so well connected to the phone’s hotspot, if no other wifi is configured in RS2). Then reachview should be able to find the RS2. (on that same phone)

I thought the same thing up to last week when someone pointed out that it should work with one device, which it did when I tried it. I think the two devices thing was true in the past but it’s changed along the way.

1 Like

Hey everyone,

Let me clear it up a little.

You can connect to the Reach device by the phone that you provide your hotspot from. You don’t need another device to connect Reach to and use the hotspot on.

Dave @dave.calder, please check the network LED of your Reach RS2 as Andy suggested. If it’s white, it means that the unit is broadcasting the hot spot. Then, you need to check available Wi-Fi networks on your Android device and connect to the hotspot. Then you’ll be able to see the unit in the ReachView App.

If the network LED is blue, your device is connected to the Wi-Fi network. Then you need to check the settings of your mobile hotspot to ensure that the unit is connected to this particular hot spot. If not, then the unit is connected to another W-Fi network. Connect your Android device to it and you will see the Reach in the App as well.

Please let us know if you’re able to see the receiver in the App.


I just tried it with my Samsung Galaxy S8 Active. I connected my RS2 to my Samsung’s hotspot, and then opened the Reachview App and it could not find the unit. It may be a device dependent issue (My google Pixe can’t find the unit even when it is connected to the rover’s own hotspot!).


It’d be great if you checked whether you can access the Reach via the browser. For that, type Reach’s IP to the address bar of the Internet browser on the device that is connected to the same network as Reach.


Please see the attached photos.

First photo is laptop connected to Samsung hotspot. Second is my Samsung hotspot showing the Rover and its IP address. Third is the blue indicator on the RS2. the 4th is the Reachview app on the same Samsung that is providing the hotspot.

Then it might be model-specific. I changed phones along the way and just never tried using only the hotspot phone until last week.

I had the same exact issue with my old phone, the RS2 would never appear either on the app or in a browser.

1 Like


Thanks for the photos!

The unit can connect to the hot spot, from what I can see. I’m afraid that this issue is indeed related to the specifics of Android OS on certain devices.

It appears not on all Android systems, so I believe the workaround here is to either use another Android device or stick to the browser version of the App. You can open it on your phone as well.

This issue should not be present while accessing the device with the ReachView 3 beta app. You can check how you can work with it in this community forum thread.

1 Like


Thanks. I suspected it was a device-to-device issue. So I suppose both ways at the moment are correct!

1 Like

A post was split to a new topic: Can’t enable mobile data on RS2

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.