Can't connect to Reach in Emlid Flow

I have the same problem, my Google Pixel 4a just does won’t connect it displays ‘can’t connect to reach’ I tried the suggestion to disable ‘battery optimization’ but no luck. Whilst my old iphone 2 does work.

Everything was working perfectly when I bought the units a couple of years ago and used the reach view app. No I have a “outdated” system and new software Emlid Flow I have wasted so much time and money (flights to West Africa) and I still did not manage to get it back to work. Extremely frustrated about this.

Hi @michielluijken,

Let’s try to connect to the unit via the Reach Panel. If your Reach is in hotspot mode (the network LED is solid white), let’s use the IP address in any browser.

If it’s connected to a network (the network LED is solid blue), let’s check with a network scanner tool to which network it is connected. You’ll see the IP address for Reach in the network scanner app, and you can use it to access the Reach Panel.

If you can connect there, let’s update Reach to the latest firmware version and try the connection in Emlid Flow again.

Hi Kornel, thank you very much.
After connecting through the panel on my laptop it worked
I tried everything to connect through my phone only but this did the trick