Can't connect to a known wifi network after update

Hi all .
Am having issues after updating my rs2 to the latest dev firm ware.
1- I can’t connect to a known wifi network yet it’s on.
2- I can’t connect to NTRIP neither can I download a source list .
Here is a simple system report.

Simple system report
app version: 2.23.7-dev-r0
'wifi_status, interface: wlan0':
- wifi_mode: ap
- access_point:
    band: bg
    channel: 1
    password: null
  ip: 192.168.42.1
  is_added: true
  is_connected: true
  mac_address: 6C:21:A2:BF:81:EC
  security: wpa-psk
  ssid: reach:99:CD
  uuid: 4f9ae6a1-e37d-42ad-aa5d-dddc888d1f27
base mode:
  base coordinates:
    accumulation: 2.0
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    coordinates:
    - 0
    - 0
    - 0
    format: llh
    mode: single-and-hold
  output:
    baud_rate: 38400
    device: UART
    enabled: false
    io_type: serial
  rtcm3 messages:
    '1006':
      enabled: true
      frequency: 0.10000000000000001
    '1074':
      enabled: true
      frequency: 1.0
    '1084':
      enabled: true
      frequency: 1.0
    '1094':
      enabled: false
      frequency: 1.0
    '1124':
      enabled: false
      frequency: 1.0
bluetooth:
  discoverable: true
  enabled: true
  pin: '***'
constraints:
  lora:
    frequency:
    - - 863000
      - 928000
correction input:
  input2:
    address: ugrf.go.ug
    enabled: true
    io_type: ntripcli
    mount_point: GULU
    password: '***'
    port: 2101
    send_position_to_base: true
    username: amizo
device:
  emit_telemetry: false
  night_mode: false
  power_on_bottom_connector: true
logging:
  base:
    format: RINEX
    started: true
    version: '3.00'
  correction:
    format: RTCM3
    started: true
  debug: false
  interval: 24
  overwrite: true
  raw:
    format: RINEX
    started: true
    version: '3.00'
  solution:
    format: LLH
    started: true
lora:
  air rate: 2.6000000000000001
  frequency: 868000
  mode: read
  output power: 20.0
network:
  tcp_over_modem: true
position output:
  output1:
    enabled: true
    format: NMEA
    io_type: bluetooth
  output2:
    baud_rate: 38400
    device: UART
    enabled: false
    format: ERB
    io_type: serial
rtk settings:
  elevation mask angle: 15
  glonass ar mode: 'off'
  gps ar mode: fix-and-hold
  max horizontal acceleration: 1.0
  max vertical acceleration: 1.0
  positioning mode: kinematic
  positioning systems:
    compass: true
    galileo: true
    glonass: true
    gps: true
    qzss: true
  snr mask: 35
  update rate: 1
sound:
  mute: false
  volume: 100

Any help is appreciated

Hi Matt,

Let me ask some of the questions below.

Do I understand correctly that you were able to connect to this network prior to the update? Please note that Reach receivers are working with the 2.4 GHz networks only.

May I ask you to specify if you provide the unit with the internet via the cellular modem? Is there any indication of the error that prevents the unit from connecting to the NTRIP service?

1 Like


Hi Polina that’s the screen shot of the network am trying to connect to.
Everything worked perfectly before the update
And yes the rs2 has full internet access because it even shares during hotspot mode.


Hope this video can help

Hi Matt,

Does your receiver able to connect to a different Wi-Fi network?

Also, it looks like your receiver repeatedly losing connection with the NTRIP server. It might be a connection issue over a cellular network.

May I ask you to download a full system report and send it to support@emlid.com so that we can examine it?

1 Like

Hi I have sent the full system report to emlid support.
After resetting the rs2 I have been able to connect to NTRIP.


But the issue of wifi still persists.
Am yet to check the reliability of this fix against known controls .

I have reflashed firm ware but it has just worsened the situation coz I can’t get past this


As it neither connects nor sees wifi networks.
It’s too disturbing.

Hi Matt,

May I ask you to specify if you tried different Wi-Fi networks to update? Have you tried the hotspot of your smartphone?

Would it be possible to describe the LED status of the receiver while you’re trying to connect it to the Wi-Fi network? Does the LED network start blinking rapidly in search of the network?

1 Like

Hello Polina .
It’s the smart phone am using .
The machine blinks blue rapidly trying to connect to the network but after it fails and returns to solid white ( hotspot mode)

Matt,

Just to be sure, have you double-checked the password and the SSID? Have you tried connecting to your local Wi-Fi or other device’s hotspot?

Hi .
Yeah the WiFi is open. I will try to check with other wifi network and see if it can work. thanks

Matt,

Have you had a chance to check another Wi-Fi network? Does the issue still persist?

1 Like

Hi Polina - regarding mattfrederick6’s wifi issues this seems identical to my posted problem after upgrade. I aslo tried flashing one unit and have the same further problem getting past the non working hotspot. Thanks.

1 Like

Hi Polina
I have tried more wifi networks but some work others don’t so it’s a gamble.
I was waiting for @mikhail.goryachev mikhail to give me the results after examining the full system report

Hi @mikhail.goryachev @polina.buriak have you found out anything yet regarding the issue?

Hi Matt,

Sorry for the delayed reply!

Please contact us on support@emlid.com with the following information:

  • order date and number
  • Reach RS2 Serial Number (you can find it by scanning the QR code under the SIM card slot)
  • your shipping address

Hi I have sent it .
But please let me know quick because am having an upcoming project where I want to use this machine.

Hey there,

Just wanted to say that we’ll be checking what could be the issue with the unit ourselves.

1 Like