Can't Connect Reach RS2 To Phone or iPad through WiFi

Reach RS2 is connected to my WiFi (WiFi light is solid blue) and Android phone is attached to the same WiFi network. Message “Reach is connection to another network. Switch to to continue” was displayed and another one indicating to refresh but there is no refresh button. Restarted ReachView several times and nothing worked. Tried on two Reach units and Android phone and iPad.

Are there any other networks that it could be hopping on before it hits the correct connection? This happen to me if I accidentally leave on a hotspot or if I want to connect to the hotspot and it had already jumped on my home WiFi. I just clear out the unwanted networks and reconnect.

Hi James,

Welcome to the community forum!

Does the issue persist with other Wi-Fi networks? Let’s also check how it works with the mobile hotspot. Here is the guide that can help you test it.

I also agree with Michael’s thoughts, Reach indeed may have switched to another available Wi-Fi network. So removing all the known networks from the list in the Wi-Fi tab and then adding just the necessary one back may help.

And just a small comment about the Refresh button. To see it, you need to go back to the list of available devices in ReachView 3.

1 Like

Thanks for your suggestions. I can see the Refresh button on my phone and iPad. Also, the web page for the SuddenLink router shows that the Reach units, my iPad, and my phone are all connected to the same network. I would try to a hotspot but how do you get the Reach unit to change WiFi networks? I tried a hard reset and it just connects to the SuddenLink router again which means I can’t get ReachView to see it. Is there another way to get the Reach unit to go back to being a hotspot?
Thanks,
Jim

Jim,

Oh, I see, scanning the Wi-Fi network is a good idea. Now we can be sure that devices are in the same network.

To get the receiver back to hotspot mode, you can carry it to a place where your Wi-Fi network is unavailable and restart the device. Or just turn off the Wi-Fi router for some time, if it’s possible.

By the way, what version of the ReachView 3 app do you use? You can check it in the Profile tab.

Turning off my Internet router (which is also my WiFi) and then turning on the Reach units allowed me to connect to the Reach units again. Using a hot spot on my Android phone and an iPad to run ReachView worked to connect to the Reach units and then switch them to the hot spot and then I could update the firmware. Also, I am using ReviewView 3 version 6.15.

1 Like

Hi there,

Jim, thanks for posting the update!

As Reach RS2 works fine with other networks, the issue seems to be related to the router’s network itself. We’re discussing it with Jim via email, but I just want to share some suggestions here as well.

Wi-Fi network may work on 2 frequencies simultaneously. In this case, Reach RS2 may connect to one of them and your phone to another. To avoid it, you can try to leave only 2.4 GHz working on a router and then check if Reach became discoverable in the app.

Also, there are networks where the router and access points are separated. And same here, it may lead to Reach RS2 connected to the router while your phone is connected to the access point, or vice versa.

Overall, I’d call these reasons related to the unusual Wi-Fi network scheme. So if you face such an issue, I’d recommend you check if your network has something like this.

Julia,
I’m not sure how unusual this is but I would still recommend mentioning in your documentation to either use a mobile device for the router or be ready to turn off your Wi-Fi router if you use it. I do believe this issue is now resolved.
Jim

Hi Jim,

Reach RS2 should work well with both router’s Wi-Fi and mobile hotspot networks. The connection process is a bit different for them, and because of it, we provide separate guides in our docs for these workflows:

In your case router’s network, most likely, has a complicated scheme. It’s unclear what exactly prevents the connection to the receiver in ReachView 3. But we can keep investigating and try to find out why it’s going on this way.

Julia,
I am okay not using my router and we now have Wi-Fi working with the Reach units. I was just commenting that it might help folks to know that if they don’t use a mobile device, that you might have to restart your router to get back control of the Reach units. I will never connect a Reach unit to a non-mobile device again so I feel that issue is resolved.

Jim,

Alright, I see that the mobile hotspot network works fine for you.

Just want to add that if someone faces a similar issue, feel free to create a new community forum thread or get in touch with us via support@emlid.com. We’ll investigate every such case individually.