Emlid

Can't connect Navio2 to QGC


(Daniel) #1

I have the exact same problem and basically the same hardware setup (QGC is updated) as the original poster, so perhaps you could help me here. I have been following the guide you linked to and here’s the file you were asking for:

(the text in bold is being preceded by a pound sign (#))

Default settings for ArduPilot for Linux.

The file is sourced by systemd from arduplane.service

TELEM1="-A udp:192.9.200.160:14550"
TELEM2="-C /dev/ttyAMA0"

Options to pass to ArduPilot

ARDUPILOT_OPTS="$TELEM1 $TELEM2"

-A is a console switch (usually this is a Wi-Fi link)

-C is a telemetry switch

Usually this is either /dev/ttyAMA0 - UART connector on your Navio

or /dev/ttyUSB0 if you’re using a serial to USB convertor

-B or -E is used to specify non default GPS

Type “emlidtool ardupilot” for further help

Neither TELEM1 (wi-fi connection to my laptop) nor TELEM2 (a telemetry dongle connected to the Navio2) are working on QGC or Mission Planner. QGC is constantly sending the “Error writing to QHostAddress(”")1" message. Any ideas?

(oh, and the UDP box was already ticked in the Application Settings.)


QGroundControl and Navio2 connecting issue
(Tatiana Andreeva) #3

Hi @danielb,

May I ask you to share the output of sudo systemctl status arduplane?


(Daniel) #4

Here is the output from that command:

● arduplane.service - ArduPilot for Linux
Loaded: loaded (/etc/systemd/system/arduplane.service; enabled; vendor preset
Active: active (running) since Tue 2018-10-23 19:17:02 UTC; 20h ago
Docs: https://docs.emlid.com/navio2/navio-ardupilot/installation-and-runnin
Main PID: 356 (sh)
CGroup: /system.slice/arduplane.service
├─356 /bin/sh -c /usr/bin/arduplane $TELEM1 $TELEM2
└─359 /usr/bin/arduplane -A udp:192.9.200.115:14550 -C /dev/ttyAMA0

Oct 23 19:17:02 navio systemd[1]: Started ArduPilot for Linux.
Oct 23 19:17:02 navio sh[356]: Could not detect RPi version, defaulting to 2/3
lines 1-11/11 (END)


(Tatiana Andreeva) #5

Hi @danielb,

It seems ardupilot is launched correctly.

Do you have a possibility to test it with another laptop?

What’s going wrong when you tried to connect to MP?


(Daniel) #6

I think the problem was the network; I switched to a “ground control” network that was only being used by my computer and the Navio2 and it worked. I’ve been able to configure everything with QGC, but I haven’t checked to see if Mission Planner works now.


(Daniel) #7

Well, perhaps it wasn’t, as I tried the same method on a different laptop and this time it didn’t work. QGC is throwing the same “Error writing to QHostAddress(”")1" message over and over again. I’m not sure what the problem is because I followed the same process as I did for the other computer.


(Tatiana Andreeva) #8

Hi @danielb,

Could you please explain what do you mean by ground control network? Which network do you use earlier?


(Daniel) #9

The network was specifically set up for the Navio2 to connect to, so only it and computer A (going to give the two computers names to ensure clarity) are connected to the network at the same time. Earlier, I had tried to use my company’s private network (it is being used by many other computers), but I got that QHostAddress error when that happened.

It may not be a network error… I say this because computer A is connected to the ground control network and I get the error, but when laptop B connects, it works perfectly fine. The only difference between the two computers that I think is relevant is that laptop B only has one internet connection (according to a ipconfig command). Computer A has several internet connections other than the “ground control” network, like WLAN and virtual machines, so do you think that could be throwing it off?


(Tatiana Andreeva) #10

Hi @danielb,

Sorry for the delayed response.

What’s the network configurations of the computer A? Could you please look into framework settings? Is it possible the framework drops the connection with Navio2?


(Daniel) #11

I’m not sure what you mean by “framework”… are you looking for a ipconfig dump?


(Tatiana Andreeva) #12

Hi @danielb,

Sorry, I’ve meant Windows firewall configurations in my previous message. You can find it in “Network & Internet” Settings. Please try to establish the connection between Ardupilot and GCS with the disabled firewall. It allows to understand if the issue occurs because of it or not.

Could you please share the output of ipconfig as well?


(Daniel) #14

I was about to set up the system and try without the firewall, but now Computer A was able to connect to the Navio2 without any problems. Perhaps I forgot to check the IP addresses when I switched the computers, but I’m not convinced I made this mistake.

For anyone else reading who might have the same problem, the steps I did to ensure the correct IP addresses were:
A) Do an “ip a” command on the raspberry pi to learn its IP address. In QGroundControl, set up a comm. link with that address as a 14550 UDP connection.
B) Do an “ipconfig” on your computer to learn its IP address. On the raspberry pi, do a “sudo nano /etc/default/arduplane” (or whichever ardu module you’re using) and edit the “udp:” line to have the computer’s IP address.
C) Reboot the Navio2/rspi and QGroundControl should connect now.

So it wasn’t a firewall issue, and I can’t tell if it was a network error… but I’ll be back if anything else goes wrong.