Can't clone ArduPilot to Navio

Hello guys!

I’m having a problem trying to clone ArduPilot and build it from sources, according to the tutorial here.
When I run git clone, all works fine.
But when I try to download the submodules via git submodule update --init, it doesn’t work.
Also, running git clone --recursive shows the same error from above.

A screenshot of the error can be seen here (this message shows up after a loooooong time, ~6 minutes waiting):

One last information: I can’t make it clone even in Windows, via GitHub for Desktop. Anybody knows if this is a problem with Git or ArduPilot code? I find it hard to think it’s an issue with my system or connection, because I cloned MissionPlanner just fine.

I solved this problem (after two days of work) editing the .gitmodules file inside ardupilot directory.

  1. git clone
  2. cd ardupilot
  3. nano .gitmodules
  4. Replace every git: with https:

I’m not sure, but I guess my university’s firewall blocks the git protocol. I don’t know much about these protocols, but I guess maybe they could replace it in the master repo