Cant calibrate Compass Navio+


I got a problem with my NAVIO+. I cant get it to calibrate the Compass, Mission Planner shows Compass 1 error: 99. Before updating to ArduPlane 3.3 everything worked just fine (Could be a coincidence).

I could manage to calibrate it, but then the HUD was showing “Error compass Variance” or “Bad AHRS”.

At the end there are pictures of the configuration inside mission planner.

Thank you for your Help.

Compass settings

I had the same problem so i decided to try ArduPlane.elf it is working ok. I just followed the link below. I am using ubuntu 14.04lts and APM planner2. I hope this helps.


now it is working for me too.
Thanks for your time!


Did you build the arduplane from the source as stated in the link?
I too have the same problem with the compass when powered by a lipo, if I power only the raspberry with a cell phone charger it works.
Reason I asked about building from source is that it doesnt work for traditional helicopter for me in mission planner.

Hi, yes i did build it from the code but, after that i found a link from DIY drones with all the codes(link below) you can choose the one you need and test. If you decide to build yourself, yes you need some knowledge on the linux it is a little complicated, it took me some time but i did and i am not a linux expert, i just like to learn about it. I hope you have success!!! Let us know if it works for you.

DIY Drones Firmware Download

I could build the code without problem but it seems that traditional helicopter frame didnt work in that version,
Strangest thing though I just got compass working with arducopter 3.3.
I ran the example from the navio git to verify that the compass worked or not, and it reported it working good.
Then started arducopter and calibration was perfekt.
Seems like the example code jumpstarted the compass or something =)

That is strange, what if you remove navio from the frame and test the compass off the frame, this way you eliminate all interference that may exist. In my case i am running arducopter hexa frame, the compass calibration is perfect on arducopter.elf. I could not calibrate it on arducopter 3.3 version. I cant tell you much about helicopters. Hope you find a solution.

No worries. It works perfect now.