Cannot run gstreamer on Raspberry Pi 3

I installed gstreamer1.0(tools,plugins-good/bad) but,it does not work. I refer to

raspivid -n -w 1280 -h 720 -b 1000000 -fps 15 -t 0 -o - | gst-launch-1.0 -v fdsrc ! h264parse ! rtph264pay config-interval=10 pt=96 ! udpsink host=<remote_ip> port=9000

Here is the error message.

ERROR: from element /GstPipeline :pipeline0/GstH264Parse:h264parse0: No valid frames found before end of stream
Additional debug info :
gstbaseparse.c(1155): gst_base_parse_sink_event_dafault(): /Gstpipeline:pileline0/GstH264Parse:h264parse0
ERROR: pipeline doesn’t want to preroll

I appreciate all the help I can get.

Is the camera enabled (raspi-config) ?
If so, is it attached properly?

Have you tried running raspivid command alone? Does it have any output?

The default user Pi doesn’t have enough privilege to read from the vchiq device. If it is the case, try to add a new rule to udder:

echo 'SUBSYSTEM=="vchiq",GROUP="video",MODE="0660"' > /etc/udev/rules.d/10-vchiq-permissions.rules

and reboot.

Thank you for your response.
Yes, the camera is enabled and attached correctly.

Thank you for your response.
I typed this command but error comes up.
I searched for ways to give my user to read, and got following command.

sudo chmod a+rw /dev/vchiq

And I succeed to watch streaming video fron Pi!

Sorry for my poor English.
Thank you very much!

Allowing everyone to read and write to /dev/vchiq is not a very good idea.

Error comes up since you might not have the permission to write to /etc/udev/rules.d/

You can run that command with root privilege or open a text editor for that file and paste SUBSYSTEM=="vchiq",GROUP="video",MODE="0660" into it. So that members in group video can read and write to vchiq device.

Thank you for your advice.
I can take your suggestion and it is successful.
Thank you!