Cannot post-process single solution from M2 data

With an M2 (current firmware as of Feb. 2021) I collected a raw log in UBX format.

Before entering more difficult scenarios I wanted to postprocess this rover data (moving) using rtkpost in single mode.

Unfortunately whatever I have tried so far rtkpost calculates something (indicated by the running timestamp during processing and appending Q=5) but the resulting .pos file only contains the header and not any positions.

The M2 internal processing was able to get solutions right away, using rtkpost something is not working though. I have tried different settings but the end result remained the same and the log files do not contain obvious error messages.

How can one process M2 logs using rtkplot in single mode? Is there a howto or some special parameter?

For reference here are the corresponding obs and nav files:

Someone correct me if I’m misunderstanding, but since it’s single, can’t you just transform it using RTKCONV and use the .pos file directly? There’s no post-processing to do if there’s no base to compare it with.

1 Like

From RTKCONV I can convert the .ubx file to observations (.obs). As far as I can see it this does not generate a .pos file with positions.

When I press the “Process…” button in RTKCONV nothing happens, I have to open RKTPOST separately.

You’re right. I wasn’t in front of RTKLib. I just tried it out with an observation of mine and then your observation using RTKPost in SINGLE. It output a perfectly good .pos file in both cases.

Thank you for confirming this! With this hint I went ahead and did a little bit more digging. It looks like a bug in RTKPOST b33. When “Rec dynamics” is switched on no output is produced, when “Rec dynamics” is switched off the .pos file is generated.

The fun part: In single mode “Rec dynamics” should not matter at all (it is also greyed out).

I tested this with the newest RTKLIB b34 (not the Emlid version) and here in both cases a .pos file is generated.

1 Like

Hi Alexander,

Thanks for reporting. I’ll check it and get back to you.

Hi Alexander,

I’ve tried to process your data and several other logs in our version of RTKLib. All the files were processed correctly, both with Rec Dynamics switched ON and OFF. So, I would suggest reinstalling RTKLib to check if you use the latest version of it.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.