Cannot load custom ardupilot image. Need single copter X frame config

  1. Latest image with Raspberry Pi 3 and Navio 2 board.
  2. I need to use singlecopter in an X frame configuration and by default all that is available is the + frame configuration. I have the modified ap motors single file to allow for an X frame configuration I just cannot get the code onto the raspberry pi to compile. I have tried using a thumb drive and ssh file transfer but no dice. How can I accomplish this? I have included a picture of our build to illustrate why we need the X config. The Navio 2 will fit on the front blue plate.

1 Like

Hello there!

We’ve got elaborate instruction how to build ArduPIlot over here. I suggest reading it through. After a binary is compiled you can proceed on launching a custom binary.

Thank you for the quick reply! I am very happy with the Navio 2 board and the ROS integration. You guys are doing a great job! I have looked through and tried those documents, I am just a little confused on how I can modify certain files then build the image. Do I download the source from github then modify directly on the pi? Thanks!

UPDATE Still ongoing, was only able to compile current stable release without modifications.

UPDATE2 Solved!!

1 Like

Also when I try to compile I get this output;

pi@navio:~/ardupilot $ waf copter
Waf: Entering directory `/home/pi/ardupilot/build/navio2’
[4/4] Processing modules/mavlink/message_definitions/v1.0/ardupilotmega.xml
/usr/bin/python: can’t open file ‘/home/pi/ardupilot/modules/mavlink/pymavlink/tools/’: [Errno 2] No such file or directory

mavgen returned 2 error code
Waf: Leaving directory `/home/pi/ardupilot/build/navio2’
Build failed
-> task in ‘mavlink’ failed (exit status 2):
{task 1986035960: mavgen ardupilotmega.xml -> }
UPDATE* Fixed!