Cannot detect REACH IP address for ReachView App

Hello friends

Yesterday I received REACH RTK KIT. Im trying to configure REACH device on my MacBook. I completed Edison Setup. I am using NMAP on MacBook and put this command on terminal:
sudo nmap -sn

This is the result:

Starting Nmap 7.12 ( ) at 2016-06-08 09:07 JST
Nmap scan report for ntt.setup (
Host is up (0.0055s latency).
MAC Address: XX:XX:XX:XX:XX:XX (Some company)
Nmap scan report for
Host is up (0.0064s latency).
MAC Address: XX:XX:XX:XX:XX:XX (Some company.Inc)
Nmap scan report for
Host is up (0.0061s latency).
MAC Address: XX:XX:XX:XX:XX:XX (Some company industries)
Nmap scan report for
Host is up.
Nmap done: 256 IP addresses (4 hosts up) scanned in 2.81 seconds

I tried “” on my Safari browser to access ReachView App but it says: “Safari can’t open the page because Safari can’t connect to the server”

I am not able to detect REACH IP address which should show up as “Murata manufacturing” or anything related to REACH device.

I tried re-flashing the board but still no success.

The LED pattern is currently showing: WHITE, GREEN, BLUE, RED, PAUSE and repeat.

I want to know how to get REACH IP address to check ReachView App on my Safari browser. If you need more details, please let me know. Please help me out.

OS: OS X El Capitan (Version: 10.11.5)
Browser: Safari


I am having the same problem with windows pc and android phone.
I hope we get solution soon. I need to go to work.
I also flashed mine but it didn’t help.

If everything went well, then Reach is blinking 5 times, then pausing, and repeating.

If Reach is connected to your network, then blink #2 is BLUE. If Reach could not find your network, then blink #2 is GREEN.

If BLUE, then try:
nmap -p 80
Then try each address that shows up in your web browser. If that doesn’t work, then turn off your wireless router, and restart Reach, connect to it’s hotspot and re-do Edison setup.

If Green, then connect to Reach’s hotspot and re-do Edison setup.

Besides those suggestions, it might be better to plug Reach into your laptop and connect to it with ethernet over USB. You said you have a Mac, so the docs say it isn’t supported, but there is a workaround you could try. (In the docs, see Software Development / Connecting to Reach via SSH)

If you can do that, then just ssh to reach and run ifconfig to see what it’s wifi IP address is.

Hello @bide Thanks for your reply. I tried all methods again and again but still same. But yeah now my LED pattern is WHITE, BLUE, BLUE, RED, PAUSE, and REPEAT.
Finally I tried ethernet over USB
Attached file is the result of ifconfig. I tried all IP address on browser but it says “Failed to open page”

I just need to access ReachView App. Hope my information is enough to make you understand what I did till now. Let me know if you can help me here.
Thanks once again.


The LED pattern is OK. Judging by the ifconfig output, Reach has the address a look at the wlan0 section). So try going for this first. NMAP might always show everything.w

Hi @egor.fedorov Thanks for the reply. I tried this IP address: but Safari failed to reach this page.

I have corrected my post above with regard to the blink pattern. First white, then blue/green, etc.

If you have your ethernet over USB working, then you can access ReachView with your browser at IP address

Since you were able to ssh over USB, maybe do some network troubleshooting from Reach:
ping -c 5
If that works, then try to ping your laptop’s IP. And if that works, then you should be able to open the terminal on your laptop and ping Reach at And if that works then you should be able to access ReachView with your browser at the same IP.

If it doesn’t work, then what? Maybe you are in an area with lots of wifi routers and Reach is connecting to someone else’s router with the same ESSID? Maybe there is some kind of interference?

1 Like

Cannot access ReachView App
I have been trying to access the
reachview app without sucess.
After flashing it it does the exact
same thing. The blinking loop is
white,blue,blue,red. I am including

the screen shots for your review.
Please Help.


Your screenshots are slightly confusing. Is Reach connected to your router or to your phone. If it’s your phone, then likely this IP will be valid:

Also, you can try using http://reach.local

UPDATE: reach.local thing will not work on Android!

YAY!!! Finally!!! Its working :smiley:

I really wants to thanks everyone who answered this post. Specially @bide.
The problem was just the setup of IP address in my MacBook which I attached with this post.
I used Ethernet over USB method.

And the ReachView App is available on IP address:

Thanks once again everyone. Will back again with new question if I face anytime later.


Thank You I got that working. Now I have logs on the reachview unit but when I open Edison (D:) on the computer it says “This folder is empty”. I don’t know how to get those files downloaded to my computer.

If you want to download all the logs as a batch, then you can use the scp command in your terminal window. For example:
scp -p reach@* ./

or if you are using Windows, then download the pscp.exe program and use that from the command window in a similar way:
pscp.exe -p reach@* ./

I don’t understand how to use that. My ip is
I don’t know /* ./

Also the pscp.exe just flasheses the black box and stops.
It does nothing.

Also I wonder why when I connect reachview unit to my computer usb and my computer assigns a driver letter to it yet I cannot copy the files directly to my computer.

Sorry, I guess you are not familiar with the command window. If you are going to try it, then yes, you should substitute Reach’s IP address.

Yes, that is because you are clicking on the icon. Maybe search the internet on how to use the command window with your operating system.

I don’t really know why, but I do know that drive space you see is a different space than ReachView uses and you will not be able to access the log files in that way. You must download them with your web browser and ReachView. That is what most people do. If you still want to download them all as a batch with one command, then you will need to learn a little about the command window and the command line. If you need more help with that, then please start a new topic and we can discuss it there.