Cannot contact or configure one of the Reach modules

Similar to another user on the forum I was able to successfully connect to my 1st reach module with no problem but I am having big problems with the 2nd module.
Shortly after powering it up Module One I observed the Hotspot appear on my tablet and configured the device to join my wireless LAN.
Module One is now available on my network via my PC’s browser as expected.

However Module Two did nothing similar to the first.
I disconnected the first Reach and put it to the side.
I attempted to repeat the same procedure as I did with Module One
I plugged in the second reach module and observed the lights slowly flash from violet to white to yellow to green and then cyclically flash WHITE, BLUE, BLUE,RED, PAUSE, over and over. The device will not begin broadcasting as a Hotspot that is visible on my tablet.

How should I proceed?

I decided to reflash Module Two to make sure there was no corruption etc.
I downloaded the Intel tool and your firmware files.
Installed the JSON file per the instructions on your site.
The Flash procedure completed successfully 5 minutes and 7 seconds later.
I waited an additional 2 minutes and when there was no LED activity anymore I rebooted the Reach

Now I the lights slowly flash from violet to white to yellow to green but now the green LED just stays on solid.
Can you tell me what this light sequence means and what I should do to get a hotspot signal from the device?

Thank you

I was about to post the same issue with my first Reach module. The issues that Daniel describe are identical to the ones I am experiencing. Testing the second one now to see if it is the same.

I had the same issue previously, after flashing. I unplugged my reach, and went to my RNDIS ethernet settings to ensure that the IP address was automatic instead of the static address that was instructed in the Docs for Ethernet over USB configuration. I replugged reach in and it seemed to solve the problem, I was able to reboot reach and find a wifi hotspot to reconfigure the Wifi settings in the Edison setup. Not sure if that will help for your case too?

Okay, so I decided to plug away at this again. Since I had nothing to lose, I decided to re-flash the one working module that I had. I know it seems nonsensical to do so but I wanted to see what the typical responses would be during and after the flash procedure.

I flashed the module and it failed miserably the first time. I tried a second time and the flash took but then after joining it to my wifi network, the Fing program could detect it, I could ping it all day long but the web server in the unit was not accepting connections. So I flashed it a third time, reconfigured the IP’s again and now it is responding correctly. I do not have any answer as to why it failed the first two times. Maybe there is a bad trash collection routine for the memory locations during the flash.

Now that I had one working I did the same with the other module. It also failed the first time. The second attempt worked though.

So for those having issues, this is exactly what I did:

a) rebooted my PC
b) started Intel flash program and pre-loaded the JSON file and clicked the FLASH button on the bottom left side. I then connected the module and observed the flash process start once the module was detected.
c) walk away…it takes over 5 minutes to flash and another 2 minutes clean up and reboot…go make a sandwich and eat it. When you come back the LED will be solid. Look over the logs on the screen. There should be no errors. If there are errors then start again. Make sure you are not using a funky USB cable from your 5 year old Android phone.
d) use a tablet or phone and find the Reach device broadcasting as a HOTSPOT. Join that network with the password reachemlid
e) Open a browser on the tablet and navigate to
f) Give the device a unique name and join it to your Home wifi network.
g) Wait about one minute for the Reach to join your home network. Make sure you re-join your tablet to your Home wifi network and you can browse the internet. Open “Fing” on your tablet (if you already downloaded and installed it)
h) Find your reach device’s new IP address and note the IP address.
i) Go to a PC on your network and put that IP address in the browser and the Reach web server will serve you a page.
j) Go to LOGS tab and click on UPDATE. The click on UPDATE will appear to do nothing. Wait 60 seconds and close the browser.
k) Relaunch browser and plug in the same IP again. Your reach should now show it is updated and you can begin the rest of your journey.

Once you have one module done do the same thing for the other module. The IP will of course be different for the second module. Make sure you use Fing to discover the address of the second module.
All of this information is in the documentation.
I guess what I am trying to clarify here is the fact that you must be patient at each step and there is the possibility that it may fail. Just keep trying.

1 Like

I’m having similar problems as mentioned above but can’t get past item © listed in the last post. I’m currently unable to reflash one of my Reach modules. I’ve only had them for a few days. I was no longer able to connect to the rover through a web page on my local network through a router. Base is fine but not the rover. It was starting to hang after changing between different configs and then it wouldn’t update the status screen but would still plot a solution to RTKLIB. Eventually, I tried to do an update and reboot but still could no longer connect to it. I could see it’s IP address on my router (along with MAC address). As a last resort I decided to reflash the firmware. Here are the error messages I get when using both the GUI and script method in WIndows.

The script method asks for the board to rebooted after plugging it in. How do I do that? Currently, the module just keeps flashing a white-blue-blue-red pattern continuously. I’ve rebooted my computer this morning and tried both methods again. Any suggestions of what to try next would be appreciated. Thanks.

1 Like

I’ve re-installed the Phone Flash Tool Lite and the Intel drivers. I now I only get 38% complete as shown next:

Using the terminal method stops and says “Dfu device not found Timeout”.
Then it suggests using the --recovery option with the script.
So I tried “flashall.bat --recovery”.
I then get:
Starting Recovery mode
Please plug and reboot the board
Flashing IFWI
!!! You should install xfstk tools, please visit

But it looks like xfstk is a linux program.

Any suggestions would be greatly appreciated. Thanks.

Hello robins,

Please tell me more info about what was done with the rover unit. Did you connect it to your home network?
Have you been able to open the rover’s app, or this is where the problems have started?

Also, what version of Windows are you using? We had a report about a problem with flashing on Windows 7.
Before digging deeper into the problem, I could also suggest trying to flash with a different USB cable.

Thanks for the Windows warning.

In summary, I could not get Windows 7 or XP to flash an image. However, I did get it to flash the image on the first try using an old computer with Ubuntu 14.04 and the awesome instructions found here: I did try to build xFSTK myself (see here: but then noticed the attached copy on the first post and saved myself more grief.

Changing USB cables didn’t fix the problem. Low quality cables made it worse and most others got me as far as the Emlid supplied cable.

Here’s a copy of the instructions. Hopefully the font doesn’t get too small.

Thank you for the feedback, we will look into the problems with windows.

Did you flash with the --recovery option? Was there a problem without it on Linux?

Linux did not need the --recovery option. I just typed “sudo ./” and it worked perfectly without any error messages. This was done on a 32 bit machine after a few hours of prep work as mentioned in my previous message. I believe the “Flash Tool Lite” will only work on 64 bit machines anyway.

I just tried to re-flash a working module using Windows 7 and XP thinking that I might get better results. I didn’t get any further than yesterday. Some more screen images are shown below.

Windows 7

XP - using a working module

XP - attempting to install USB driver with “bricked” module (yesterday)

I run XP on the same 32 bit machine I run Ubuntu on. Unfortunately, I was not able to figure out the USB driver for XP. This is even after installing the drivers from Intel. The flashing error from the terminal was similar to Windows 7. With Googling this error, I ended up at and then at The problem with Zadig is that I’m not 100% sure which driver to install. Sometimes it showed a CDC and sometimes it shows RNDIS. It’s constantly changing and XP keeps popping up the “Found New Hardware” message.

After all that here’s my summary,
Windows 7 Pro 64 bit - won’t work
XP Pro 32 bit - won’t work
Ubuntu 32 bit - works


Thanks for all the debug info!

On reasonably recent versions of Ubuntu we had no problems with flashing at all. The xFSTK dependency was only required to run the flashall script with --recovery option for severely misconfigured devices.

I will try and look into the whole flashing process.


I started and stopped both of my Reach modules many times and most of the time they started normally. Now one is not working. The Config page has a circle of dots that keep rotating and the Reach module is flashing an orange LED constantly.

I bought a TW2405 antenna and for the first time I was able to get a fix and have the Reach stay in fix for many hours. So I decided to disconnect the Reach and then watch for how long it would take to get a fix again. After reconnecting the module to USB power I have not been able to get it working after hours of trying.

I have tried updating and rebooting many times with no results. After trying many times to get the module to work I did click on the button on the settings page to Turn off WiFi. The message said that Wifi would come back on after a power cycle but it’s still not working.

Is there a way to get the module working again that does not require the flashing of firmware?


I will need for info in order to help you.

Can you remember any of the circumstances of when you disconnected Reach(when it was still working ok)?
Is the WiFi working? Can you ping the device in your home network? What are the LED statuses?

Also, could you try clearing your browser’s cache? Sometimes it messes around with the app


I will need for info in order to help you.

Can you remember any of the circumstances of when you disconnected Reach(when it was still working ok)?

Yes, I can remember exactly the circumstances of disconnecting the Reach. I connected the Reach to my new TW2405 antenna and I let it run for 6 hours. I decided to disconnect the USB connection to test how fast I would be able to get a fix solution after a loss of power.

I carefully reconnected the USB cable to the same 110v power converter that I was using and now I can’t get any data from the Reach.

Is the WiFi working? Can you ping the device in your home network? What are the LED statuses?

I can connect to the Reach module very quickly and I can move through all the pages in the Reach app. I posted the Config page above and here are the screen shots of the Log, Status and settings pages. The LED on the Reach is continuously flashing an orange color LED

Also, could you try clearing your browser’s cache? Sometimes it messes around with the app

I guess I could find out how to clear my browser if you think it’s needed.



I get the same problem with the Reach when I connect to the Reach using it’s hot spot.

Is the LED flashing orange? That means it’s trying to acquire current time. The thing is, without correct system time set, devices tend to malfunction. Because of this, we decided to not start any processing until a valid time is set either via an Internet connection or GPS.

My guess is something going wrong with setting the time via the internet, so Reach is waiting for GPS to provide it.
Can you try to connect an antenna(you don’t need ideal environment like RTK requires) and try to just put it out of the window? In about 30 seconds the orange flashing should stop.


I was outside in an open area where I was getting the CORS data from the internet and the Reach was set for GPS and Glonass. I disconnected the power and reconnected the power a half a minute later. I did not move the Reach just cycled the power. I was able to connect to the Reach module through the Wifi router which is connected to the internet.

I left the Reach on for an hour and tried to get the it working. I than cycled the power and tried a number of times to get it restarted. Nothing has changed. I’ll send you a video of the Reach trying to start if you like.

The TW2405 antenna gave me great accuracy. I did notice though that I only received signals for satellite who’s identifier started with G. Often some of the satellites had low signal strength but the accuracy always was within a few centimeters.

I’ve had the Reach restarted many times, for a number of hours while connected to the internet and the orange LED has kept flashing.

I replaced the antenna with the one from the kit and the orange LED continues to flash.

My guess is that there’s a bug in the latest firmware update.


I assume there’s a warning in ReachView about the time?


I’ve not seen any warning on any page of ReachView.

The only setting that is changed from the way it was set is the Rinex version is now 2.10 and I think it was 3.01 before it stopped working.

I’m not able to change any of the settings in ReachView now.

Nothing has changed from what you see in the screen- shots that I posted above.



I would really like to get my Reach working again.

Is there any way to get the Reach to work again?

The TW2405 antenna may have caused my problem because when I was using the new antenna I noticed that there was only GPS satellites on the status page.

The TW2405 is both a GPS and Glonass antenna but because it’s a larger antenna it may be able to reach 10 GPS satellites.

If you’re only getting time from Glonass satellites that may be the cause of my problem.